aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2017-04-22 09:45:23 +0200
committerMattias Andrée <maandree@kth.se>2017-04-22 09:45:23 +0200
commitba4c4e6bcca908b260f24014a55b394c512aa8ce (patch)
tree6fc7aba840999cd048f1326ed523c68d86c332bb
parentUpdate pylibcoopgamma (diff)
downloadaur-packages-ba4c4e6bcca908b260f24014a55b394c512aa8ce.tar.gz
aur-packages-ba4c4e6bcca908b260f24014a55b394c512aa8ce.tar.bz2
aur-packages-ba4c4e6bcca908b260f24014a55b394c512aa8ce.tar.xz
Add pylibgamma
Signed-off-by: Mattias Andrée <maandree@kth.se>
-rw-r--r--pylibgamma/PKGBUILD26
l---------pylibgamma/upload1
2 files changed, 27 insertions, 0 deletions
diff --git a/pylibgamma/PKGBUILD b/pylibgamma/PKGBUILD
new file mode 100644
index 0000000..268d18e
--- /dev/null
+++ b/pylibgamma/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=pylibgamma
+pkgver=1.1.2
+pkgrel=1
+pkgdesc="Display server abstraction layer for gamma ramps and Python 3"
+arch=(i686 x86_64)
+url="https://github.com/maandree/pylibgamma"
+license=('GPL3')
+depends=(python3 'libgamma>=0.6' glibc)
+makedepends=(python3 'libgamma>=0.6' glibc make gcc cython coreutils pkg-config)
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(e40f1291712e799d28eb4b4c5df9fe6b07ce5f0bf39bcd7f9416fb9d3335fb9a)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr PY_MAJOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1)" PY_MINOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 2)"
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr PY_MAJOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 1)" PY_MINOR="$(python -V | cut -d ' ' -f 2 | cut -d . -f 2)" install DESTDIR="$pkgdir"
+}
+
diff --git a/pylibgamma/upload b/pylibgamma/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/pylibgamma/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file