diff options
author | Mattias Andrée <maandree@operamail.com> | 2012-11-20 06:59:39 +0100 |
---|---|---|
committer | Mattias Andrée <maandree@operamail.com> | 2012-11-20 06:59:39 +0100 |
commit | 9ae73081f438595c95aa836a62c7ae5465748d70 (patch) | |
tree | e10d8df993294770afb20f218e9fbb0d50147d33 | |
parent | due not notify about a package being unfetchable twice, now that running this is automated. (diff) | |
download | aur-packages-9ae73081f438595c95aa836a62c7ae5465748d70.tar.gz aur-packages-9ae73081f438595c95aa836a62c7ae5465748d70.tar.bz2 aur-packages-9ae73081f438595c95aa836a62c7ae5465748d70.tar.xz |
gitignore improvment + remove file to be downloaded if it already exists
Signed-off-by: Mattias Andrée <maandree@operamail.com>
-rw-r--r-- | .gitignore | 1 | ||||
-rwxr-xr-x | blender-plugin-vectex/watch | 1 | ||||
-rw-r--r-- | cedilla/.gitignore | 1 | ||||
-rwxr-xr-x | cedilla/watch | 1 | ||||
-rwxr-xr-x | dooble/watch | 1 | ||||
-rwxr-xr-x | emacs-gtk2/watch | 3 | ||||
-rwxr-xr-x | javagnutar/watch | 1 | ||||
-rw-r--r-- | pony/.gitignore | 1 | ||||
-rwxr-xr-x | pony/watch | 1 | ||||
-rwxr-xr-x | python2-numpydoc/watch | 1 | ||||
-rwxr-xr-x | qtsixa/watch | 1 | ||||
-rw-r--r-- | rssyl/.gitignore | 1 | ||||
-rwxr-xr-x | rssyl/watch | 1 | ||||
-rwxr-xr-x | xz-java/watch | 1 |
14 files changed, 16 insertions, 0 deletions
@@ -17,3 +17,4 @@ pkg/ *.new *.old *.diff +index.* diff --git a/blender-plugin-vectex/watch b/blender-plugin-vectex/watch index f1502d2..953ad61 100755 --- a/blender-plugin-vectex/watch +++ b/blender-plugin-vectex/watch @@ -1,5 +1,6 @@ #!/bin/sh +[ -f 'index.html' ] && rm 'index.html' wget http://code.google.com/p/vectex/ >/dev/null 2>/dev/null if [ $? = 0 ]; then [ -f unfetchable ] && rm unfetchable diff --git a/cedilla/.gitignore b/cedilla/.gitignore new file mode 100644 index 0000000..7f65160 --- /dev/null +++ b/cedilla/.gitignore @@ -0,0 +1 @@ +/NEWS.text diff --git a/cedilla/watch b/cedilla/watch index f319765..b59d99b 100755 --- a/cedilla/watch +++ b/cedilla/watch @@ -1,5 +1,6 @@ #!/bin/sh +[ -f 'NEWS.text' ] && rm 'NEWS.text' wget 'http://www.pps.univ-paris-diderot.fr/~jch/software/cedilla/NEWS.text' >/dev/null 2>/dev/null if [ $? = 0 ]; then [ -f unfetchable ] && rm unfetchable diff --git a/dooble/watch b/dooble/watch index a1e2ddf..fd24abe 100755 --- a/dooble/watch +++ b/dooble/watch @@ -1,5 +1,6 @@ #!/bin/sh +[ -f 'index.html' ] && rm 'index.html' wget http://dooble.sourceforge.net/ >/dev/null 2>/dev/null if [ $? = 0 ]; then [ -f unfetchable ] && rm unfetchable diff --git a/emacs-gtk2/watch b/emacs-gtk2/watch index 6a52673..50e5aad 100755 --- a/emacs-gtk2/watch +++ b/emacs-gtk2/watch @@ -1,5 +1,8 @@ #!/bin/sh +[ -f 'PKGBUILD?h=packages%2Femacs' ] && rm 'PKGBUILD?h=packages%2Femacs' +[ -f 'emacs.install?h=packages%2Femacs' ] && rm 'emacs.install?h=packages%2Femacs' + wget 'https://projects.archlinux.org/svntogit/packages.git/plain/trunk/PKGBUILD?h=packages/emacs' >/dev/null 2>/dev/null wget 'https://projects.archlinux.org/svntogit/packages.git/plain/trunk/emacs.install?h=packages/emacs' >/dev/null 2>/dev/null diff --git a/javagnutar/watch b/javagnutar/watch index d8790df..870a79a 100755 --- a/javagnutar/watch +++ b/javagnutar/watch @@ -1,5 +1,6 @@ #!/bin/sh +[ -f 'index.html' ] && rm 'index.html' wget http://code.google.com/p/javagnutar/ >/dev/null 2>/dev/null if [ $? = 0 ]; then [ -f unfetchable ] && rm unfetchable diff --git a/pony/.gitignore b/pony/.gitignore new file mode 100644 index 0000000..4139e4a --- /dev/null +++ b/pony/.gitignore @@ -0,0 +1 @@ +/pony @@ -1,5 +1,6 @@ #!/bin/sh +[ -f 'pony' ] && rm 'pony' wget http://hackage.haskell.org/package/pony >/dev/null 2>/dev/null if [ $? = 0 ]; then [ -f unfetchable ] && rm unfetchable diff --git a/python2-numpydoc/watch b/python2-numpydoc/watch index e10f310..f66d1e4 100755 --- a/python2-numpydoc/watch +++ b/python2-numpydoc/watch @@ -1,5 +1,6 @@ #!/bin/sh +[ -f 'index.html' ] && rm 'index.html' wget http://pypi.python.org/packages/source/n/numpydoc/ >/dev/null 2>/dev/null if [ $? = 0 ]; then [ -f unfetchable ] && rm unfetchable diff --git a/qtsixa/watch b/qtsixa/watch index cb8648c..edce4fa 100755 --- a/qtsixa/watch +++ b/qtsixa/watch @@ -1,5 +1,6 @@ #!/bin/sh +[ -f 'index.html' ] && rm 'index.html' wget http://sourceforge.net/projects/qtsixa/files/ >/dev/null 2>/dev/null if [ $? = 0 ]; then [ -f unfetchable ] && rm unfetchable diff --git a/rssyl/.gitignore b/rssyl/.gitignore new file mode 100644 index 0000000..98ecdaf --- /dev/null +++ b/rssyl/.gitignore @@ -0,0 +1 @@ +/plugins.* diff --git a/rssyl/watch b/rssyl/watch index 8aeed7f..13b728f 100755 --- a/rssyl/watch +++ b/rssyl/watch @@ -1,5 +1,6 @@ #!/bin/sh +[ -f 'plugins.php?branch=EXT' ] && rm 'plugins.php?branch=EXT' wget 'http://www.claws-mail.org/plugins.php?branch=EXT' >/dev/null 2>/dev/null if [ $? = 0 ]; then [ -f unfetchable ] && rm unfetchable diff --git a/xz-java/watch b/xz-java/watch index e8bfc5f..129ce7f 100755 --- a/xz-java/watch +++ b/xz-java/watch @@ -1,5 +1,6 @@ #!/bin/sh +[ -f 'index.html?p=xz-java.git;a=blob_plain;f=NEWS;hb=HEAD' ] && rm 'index.html?p=xz-java.git;a=blob_plain;f=NEWS;hb=HEAD' wget 'http://git.tukaani.org/?p=xz-java.git;a=blob_plain;f=NEWS;hb=HEAD' >/dev/null 2>/dev/null if [ $? = 0 ]; then [ -f unfetchable ] && rm unfetchable |