aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2023-11-18 10:56:53 +0100
committerMattias Andrée <maandree@kth.se>2023-11-18 10:56:53 +0100
commit79e716d2b53802606ab30addf86fbe20eec53596 (patch)
tree01cdcd36c85d158155f6963948db93bd360441df
parentUpdate xpybar to version 1.20.2 (diff)
downloadaur-packages-79e716d2b53802606ab30addf86fbe20eec53596.tar.gz
aur-packages-79e716d2b53802606ab30addf86fbe20eec53596.tar.bz2
aur-packages-79e716d2b53802606ab30addf86fbe20eec53596.tar.xz
Add sshexec
Signed-off-by: Mattias Andrée <maandree@kth.se>
-rw-r--r--sshexec/PKGBUILD21
l---------sshexec/upload1
2 files changed, 22 insertions, 0 deletions
diff --git a/sshexec/PKGBUILD b/sshexec/PKGBUILD
new file mode 100644
index 0000000..101f73d
--- /dev/null
+++ b/sshexec/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+pkgname=sshexec
+pkgver=1.0
+pkgrel=1
+pkgdesc="SSH wrapper that makes it easy to run commands directly in the SSH command"
+arch=('x86_64')
+url="https://codeberg.org/maandree/sshexec"
+license=('custom:ISC')
+depends=(openssh)
+source=(sshexec-$pkgver.tar.gz::${url}/archive/${pkgver}.tar.gz)
+sha256sums=(946b7068a55d33cf16f07727ac50ec0cfa52245c0114cebbe355409700e631e4)
+
+build() {
+ cd "${srcdir}/sshexec"
+ make DESTDIR="${pkgdir}/" PREFIX=/usr
+}
+
+package() {
+ cd "${srcdir}/sshexec"
+ make DESTDIR="${pkgdir}/" PREFIX=/usr install
+}
diff --git a/sshexec/upload b/sshexec/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/sshexec/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file