aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattias Andrée <maandree@operamail.com>2015-04-14 18:17:22 +0200
committerMattias Andrée <maandree@operamail.com>2015-04-14 18:17:22 +0200
commit111582f9c06658586a549b3b17fc934586849dc9 (patch)
treeff77888004ed049f01a13c993d8c6492e1d7867f
parentm + update dooble (diff)
downloadaur-packages-111582f9c06658586a549b3b17fc934586849dc9.tar.gz
aur-packages-111582f9c06658586a549b3b17fc934586849dc9.tar.bz2
aur-packages-111582f9c06658586a549b3b17fc934586849dc9.tar.xz
update xorg-server-hwcursor-gamma
Signed-off-by: Mattias Andrée <maandree@operamail.com>
-rw-r--r--xorg-server-hwcursor-gamma/0001-mi-Partial-pie-slice-filled-arcs-may-need-more-space.patch42
-rw-r--r--xorg-server-hwcursor-gamma/PKGBUILD6
2 files changed, 47 insertions, 1 deletions
diff --git a/xorg-server-hwcursor-gamma/0001-mi-Partial-pie-slice-filled-arcs-may-need-more-space.patch b/xorg-server-hwcursor-gamma/0001-mi-Partial-pie-slice-filled-arcs-may-need-more-space.patch
new file mode 100644
index 0000000..668ae21
--- /dev/null
+++ b/xorg-server-hwcursor-gamma/0001-mi-Partial-pie-slice-filled-arcs-may-need-more-space.patch
@@ -0,0 +1,42 @@
+From 41932dfbc841a1adc6512d41085ea3f8ebecb42c Mon Sep 17 00:00:00 2001
+From: Keith Packard <keithp@keithp.com>
+Date: Wed, 8 Apr 2015 07:45:28 -0700
+Subject: [PATCH] mi: Partial pie-slice filled arcs may need more space for
+ spans
+
+The mi filled arc code estimates that a filled arc will produce no
+more spans than the arc is tall. This is true for most arcs except
+for pie-slice arcs strictly between 180 and 360 degrees where the missing
+portion of the arc faces up or down such that we get two spans on some
+scanlines.
+
+For those, we need to reserve room for another height/2 spans. This
+patch just does it for all partial pie-sliced arcs to make the test
+easier to understand; it's just over-allocating a bit of memory, so
+that's safe.
+
+Signed-off-by: Keith Packard <keithp@keithp.com>
+Reviewed-by: Adam Jackson <ajax@redhat.com>
+---
+ mi/mifillarc.c | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/mi/mifillarc.c b/mi/mifillarc.c
+index 246d70f..888519e 100644
+--- a/mi/mifillarc.c
++++ b/mi/mifillarc.c
+@@ -660,6 +660,11 @@ miPolyFillArc(DrawablePtr pDraw, GCPtr pGC, int narcs_all, xArc * parcs)
+ if (narcs && nspans + arc->height > MAX_SPANS_PER_LOOP)
+ break;
+ nspans += arc->height;
++
++ /* A pie-slice arc may add another pile of spans */
++ if (pGC->arcMode == ArcPieSlice &&
++ (-FULLCIRCLE < arc->angle2 && arc->angle2 < FULLCIRCLE))
++ nspans += (arc->height + 1) >> 1;
+ }
+
+ pts = points = malloc (sizeof (DDXPointRec) * nspans +
+--
+2.3.5
+
diff --git a/xorg-server-hwcursor-gamma/PKGBUILD b/xorg-server-hwcursor-gamma/PKGBUILD
index 111ec84..e4578d0 100644
--- a/xorg-server-hwcursor-gamma/PKGBUILD
+++ b/xorg-server-hwcursor-gamma/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=xorg-server
pkgname=xorg-server-hwcursor-gamma
pkgver=1.17.1
-pkgrel=4
+pkgrel=5
pkgdesc="Xorg X server with patch to apply gamma ramps on hardware cursors"
depends=(libepoxy libxdmcp libxfont libpciaccess libdrm pixman libgcrypt libxau xorg-server-common xf86-input-evdev libxshmfence libgl)
provides=("xorg-server=${pkgver}" 'X-ABI-VIDEODRV_VERSION=19' 'X-ABI-XINPUT_VERSION=21' 'X-ABI-EXTENSION_VERSION=9.0' 'x-server')
@@ -28,6 +28,7 @@ source=(${url}/releases/individual/xserver/${_pkgname}-${pkgver}.tar.bz2
os-access-fix-regression-in-server-interpreted-auth.patch
v2-xserver-Fix-a-crash-with-XDMCP-error-handler.patch
0001-int10-Fix-error-check-for-pci_device_map_legacy.patch
+ 0001-mi-Partial-pie-slice-filled-arcs-may-need-more-space.patch
0001-When-an-cursor-is-set-it-is-adjusted-to-use-the.patch
0002-Fix-for-full-and-semi-transparency-under-negative-im.patch
0003-Use-Harms-s-suggest-do-not-use-inline-if.-And-fix-si.patch)
@@ -38,6 +39,7 @@ sha256sums=('2bf8e9f6f0a710dec1d2472467bff1f4e247cb6dcd76eb469aafdc8a2d7db2ab'
'8a9d76eecf8795ca645fb1ce261733965578e953f6606153ce001a0e15d036e8'
'a73e33644682d9f430db987c192da0f7193907af50539669ebd59614a5ebd0f9'
'2ea82cdbd695f21c935710847913ed58e22d3d5c0c18c96175a4a6cc1142c071'
+ 'ca89cc013844c5b50abfde4cc5e852ecdf4368f8b069ffd069a7100843c46e90'
'bea348631dedd66475d84ac2cfe0840f22a80a642b4680d73fead4749e47f055'
'be9169b937b5d0b44f7f05d7c08aaa5f0c1092e128ce261d9cb350f09dfe1fb0'
'0a643ae83e03faee0f4db669a33c5b3c99edbba5c86cde2c83962ae536d31081')
@@ -55,6 +57,8 @@ prepare() {
patch -Np1 -i ../v2-xserver-Fix-a-crash-with-XDMCP-error-handler.patch
# fix FS#43924, merged upstream
patch -Np1 -i ../0001-int10-Fix-error-check-for-pci_device_map_legacy.patch
+ # fix FS#43937, merged upstream
+ patch -Np1 -i ../0001-mi-Partial-pie-slice-filled-arcs-may-need-more-space.patch
}
build() {