aboutsummaryrefslogtreecommitdiffstats
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2014-10-20 17:57:04 -0700
committerAlan Coopersmith <alan.coopersmith@oracle.com>2014-10-20 18:00:52 -0700
commit14bfab3bb34f5ab75f2ac6c4acb3b67201e89a69 (patch)
tree55919167f7c1c44e11887c6f4e9407ca922b7997 /man/Makefile.am
parentman: note that -n is the default mode. (diff)
downloadxcman-14bfab3bb34f5ab75f2ac6c4acb3b67201e89a69.tar.gz
xcman-14bfab3bb34f5ab75f2ac6c4acb3b67201e89a69.tar.bz2
xcman-14bfab3bb34f5ab75f2ac6c4acb3b67201e89a69.tar.xz
config: move man pages into their own directory
Use services provided by XORG_MANPAGE_SECTIONS. Use standard Makefile for man pages. Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
new file mode 100644
index 0000000..988f6ff
--- /dev/null
+++ b/man/Makefile.am
@@ -0,0 +1,12 @@
+
+appmandir = $(APP_MAN_DIR)
+appman_PRE = xcompmgr.man
+appman_DATA = $(appman_PRE:man=$(APP_MAN_SUFFIX))
+
+EXTRA_DIST = $(appman_PRE)
+CLEANFILES = $(appman_DATA)
+SUFFIXES = .$(APP_MAN_SUFFIX) .man
+
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
+.man.$(APP_MAN_SUFFIX):
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@