aboutsummaryrefslogtreecommitdiffstats
path: root/src/redshift-gtk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/redshift-gtk/Makefile.am')
-rw-r--r--src/redshift-gtk/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/redshift-gtk/Makefile.am b/src/redshift-gtk/Makefile.am
new file mode 100644
index 0000000..10242ea
--- /dev/null
+++ b/src/redshift-gtk/Makefile.am
@@ -0,0 +1,21 @@
+
+if ENABLE_GUI
+redshift_gtk_PYTHON = \
+ __init__.py \
+ utils.py \
+ statusicon.py
+nodist_redshift_gtk_PYTHON = \
+ defs.py
+redshift_gtkdir = $(pythondir)/redshift_gtk
+
+dist_bin_SCRIPTS = redshift-gtk
+endif
+
+EXTRA_DIST = defs.py.in
+CLEANFILES = defs.py
+
+
+# Local python definitions
+defs.py: defs.py.in
+ sed -e "s|\@bindir\@|$(bindir)|g" \
+ -e "s|\@localedir\@|$(localedir)|g" $< > $@