aboutsummaryrefslogtreecommitdiffstats
path: root/src/redshift-gtk/Makefile.am
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2013-03-05 23:17:54 +0100
committerJon Lund Steffensen <jonlst@gmail.com>2013-03-05 23:17:54 +0100
commit30c805f5e7fe79c465077cecd05d0afafe79dc68 (patch)
tree3a7993e925d7910f1c6692b9c961b5a4c79fc3e9 /src/redshift-gtk/Makefile.am
parentMakefile.am: Fix missing files when generating tarball. (diff)
downloadredshift-ng-30c805f5e7fe79c465077cecd05d0afafe79dc68.tar.gz
redshift-ng-30c805f5e7fe79c465077cecd05d0afafe79dc68.tar.bz2
redshift-ng-30c805f5e7fe79c465077cecd05d0afafe79dc68.tar.xz
Rename gtk-redshift -> redshift-gtk.
This is primarily for improved discovery. Some users report that they didn't know about redshift-gtk, but had it been available on tab completion they would have noticed. Also, I think it is in general good practice that closely related programs have the same prefix.
Diffstat (limited to 'src/redshift-gtk/Makefile.am')
-rw-r--r--src/redshift-gtk/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/redshift-gtk/Makefile.am b/src/redshift-gtk/Makefile.am
new file mode 100644
index 0000000..10242ea
--- /dev/null
+++ b/src/redshift-gtk/Makefile.am
@@ -0,0 +1,21 @@
+
+if ENABLE_GUI
+redshift_gtk_PYTHON = \
+ __init__.py \
+ utils.py \
+ statusicon.py
+nodist_redshift_gtk_PYTHON = \
+ defs.py
+redshift_gtkdir = $(pythondir)/redshift_gtk
+
+dist_bin_SCRIPTS = redshift-gtk
+endif
+
+EXTRA_DIST = defs.py.in
+CLEANFILES = defs.py
+
+
+# Local python definitions
+defs.py: defs.py.in
+ sed -e "s|\@bindir\@|$(bindir)|g" \
+ -e "s|\@localedir\@|$(localedir)|g" $< > $@