aboutsummaryrefslogtreecommitdiffstats
path: root/src/gtk-redshift/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gtk-redshift/Makefile.am')
-rw-r--r--src/gtk-redshift/Makefile.am24
1 files changed, 22 insertions, 2 deletions
diff --git a/src/gtk-redshift/Makefile.am b/src/gtk-redshift/Makefile.am
index d0d8695..9c8479f 100644
--- a/src/gtk-redshift/Makefile.am
+++ b/src/gtk-redshift/Makefile.am
@@ -1,5 +1,6 @@
if ENABLE_GTK
+module=statusicon
gtk_redshift_PYTHON = \
__init__.py \
statusicon.py
@@ -8,12 +9,31 @@ nodist_gtk_redshift_PYTHON = \
gtk_redshiftdir = $(pythondir)/gtk_redshift
dist_bin_SCRIPTS = gtk-redshift
-EXTRA_DIST = defs.py.in
+EXTRA_DIST = gtk-redshift.in \
+ defs.py.in
endif
-CLEANFILES = defs.py
+if ENABLE_APPINDICATOR
+module=rsappindicator
+gtk_redshift_PYTHON = \
+ __init__.py \
+ rsappindicator.py
+nodist_gtk_redshift_PYTHON = \
+ defs.py
+gtk_redshiftdir = $(pythondir)/gtk_redshift
+
+dist_bin_SCRIPTS = gtk-redshift
+EXTRA_DIST = gtk-redshift.in \
+ defs.py.in
+endif
+
+CLEANFILES = defs.py \
+ gtk-redshift
# Local python definitions
+gtk-redshift: gtk-redshift.in
+ sed -e "s|\@module\@|$(module)|g" $< > $@
+
defs.py: defs.py.in
sed -e "s|\@bindir\@|$(bindir)|g" \
-e "s|\@localedir\@|$(localedir)|g" $< > $@