aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index eca9217..8d11a03 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,6 +21,7 @@ EXTRA_redshift_SOURCES = \
gamma-drm.c gamma-drm.h \
gamma-randr.c gamma-randr.h \
gamma-vidmode.c gamma-vidmode.h \
+ gamma-quartz.c gamma-quartz.h \
gamma-w32gdi.c gamma-w32gdi.h \
location-geoclue.c location-geoclue.h
@@ -51,6 +52,13 @@ redshift_LDADD += \
$(XF86VM_LIBS) $(XF86VM_CFLAGS)
endif
+if ENABLE_QUARTZ
+redshift_SOURCES += gamma-quartz.c gamma-quartz.h
+AM_CFLAGS += $(QUARTZ_CFLAGS)
+redshift_LDADD += \
+ $(QUARTZ_LIBS) $(QUARTZ_CFLAGS)
+endif
+
if ENABLE_WINGDI
redshift_SOURCES += gamma-w32gdi.c gamma-w32gdi.h
redshift_LDADD += -lgdi32
@@ -74,3 +82,18 @@ AM_CFLAGS += \
redshift_LDADD += \
$(GEOCLUE2_LIBS) $(GEOCLUE2_CFLAGS)
endif
+
+# Build CoreLocation module as a separate convenience
+# library since it is using a separate compiler
+# (Objective C).
+
+if ENABLE_CORELOCATION
+noinst_LTLIBRARIES = liblocation-corelocation.la
+liblocation_corelocation_la_SOURCES = \
+ location-corelocation.m location-corelocation.h
+liblocation_corelocation_la_OBJCFLAGS = \
+ $(CORELOCATION_CFLAGS)
+liblocation_corelocation_la_LIBADD = \
+ $(CORELOCATION_CFLAGS) $(CORELOCATION_LIBS)
+redshift_LDADD += liblocation-corelocation.la
+endif