aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b2ee3a7..89cb47a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -20,6 +20,9 @@ PKG_CHECK_MODULES([XCB], [xcb], [have_xcb=yes], [have_xcb=no])
PKG_CHECK_MODULES([XCB_RANDR], [xcb-randr],
[have_xcb_randr=yes], [have_xcb_randr=no])
+PKG_CHECK_MODULES([GLIB], [glib-2.0], [have_glib=yes], [have_glib=no])
+PKG_CHECK_MODULES([GCONF], [gconf-2.0], [have_gconf=yes], [have_gconf=no])
+
AC_CHECK_HEADER([windows.h], [have_windows_h=yes], [have_windows_h=no])
# Check for Python
@@ -96,6 +99,28 @@ AS_IF([test "x$enable_randr" = xno -a "x$enable_vidmode" = xno -a "x$enable_wing
AC_MSG_ERROR([either RANDR, VidMode or WinGDI must be enabled])
])
+# Check GNOME Clock location provider
+AC_MSG_CHECKING([whether to enable GNOME Clock location provider])
+AC_ARG_ENABLE([gnome-clock], [AC_HELP_STRING([--enable-gnome-clock],
+ [enable GNOME Clock location provider])],
+ [enable_gnome_clock=$enableval],[enable_gnome_clock=maybe])
+AS_IF([test "x$enable_gnome_clock" != xno], [
+ AS_IF([test $have_glib = yes -a $have_gconf = yes], [
+ AC_DEFINE([ENABLE_GNOME_CLOCK], 1,
+ [Define to 1 to enable GNOME Clock location provider])
+ AC_MSG_RESULT([yes])
+ ], [
+ AC_MSG_RESULT([missing dependencies])
+ AS_IF([test "x$enable_gnome_clock" = xyes], [
+ AC_MSG_ERROR([missing dependencies for GNOME Clock location provider])
+ ])
+ enable_gnome_clock=no
+ ])
+], [
+ AC_MSG_RESULT([no])
+])
+AM_CONDITIONAL([ENABLE_GNOME_CLOCK], [test "x$enable_gnome_clock" != xno])
+
# Check for GTK+ status icon
AC_MSG_CHECKING([whether to enable GTK status icon])
AC_ARG_ENABLE([gtk], [AC_HELP_STRING([--enable-gtk],