aboutsummaryrefslogtreecommitdiffstats
path: root/src/redshift-gtk/Makefile.am
diff options
context:
space:
mode:
authorTingPing <tingping@tingping.se>2013-12-29 19:41:10 -0500
committerTingPing <tingping@tingping.se>2014-01-01 14:11:11 -0500
commit8768ba76f8b6aa760822e1c83ba82477ae601314 (patch)
treee96047211ddc4d05578ed9bbe2cfc17e593e6abc /src/redshift-gtk/Makefile.am
parentMerge pull request #19 from TingPing/patch-1 (diff)
downloadredshift-ng-8768ba76f8b6aa760822e1c83ba82477ae601314.tar.gz
redshift-ng-8768ba76f8b6aa760822e1c83ba82477ae601314.tar.bz2
redshift-ng-8768ba76f8b6aa760822e1c83ba82477ae601314.tar.xz
Port redshift-gtk to Python3
Python 2 is no longer supported
Diffstat (limited to 'src/redshift-gtk/Makefile.am')
-rw-r--r--src/redshift-gtk/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/src/redshift-gtk/Makefile.am b/src/redshift-gtk/Makefile.am
index 9eb0cdb..96d7718 100644
--- a/src/redshift-gtk/Makefile.am
+++ b/src/redshift-gtk/Makefile.am
@@ -11,11 +11,14 @@ redshift_gtkdir = $(pythondir)/redshift_gtk
dist_bin_SCRIPTS = redshift-gtk
endif
-EXTRA_DIST = defs.py.in
-CLEANFILES = defs.py
+EXTRA_DIST = defs.py.in redshift-gtk.in
+CLEANFILES = defs.py redshift-gtk
# Local python definitions
defs.py: defs.py.in
$(AM_V_GEN)sed -e "s|\@bindir\@|$(bindir)|g" \
-e "s|\@localedir\@|$(localedir)|g" $< > $@
+
+redshift-gtk: redshift-gtk.in
+ $(AM_V_GEN)sed -e "s|\@pythondir\@|$(pythondir)|g" $< > $@