aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2014-12-15 01:53:59 -0500
committerJon Lund Steffensen <jonlst@gmail.com>2014-12-15 01:53:59 -0500
commitdc78015f323f5ed3c3b7a9f2e6d9c1edcd9f77e2 (patch)
tree0e3eaac5fabbf426845423da85eda27c5297323b /src/Makefile.am
parentsystemtime: Use gettimeofday if POSIX timers not available (diff)
parentcontrib: Update RPM spec to use GeoClue2 (diff)
downloadredshift-ng-dc78015f323f5ed3c3b7a9f2e6d9c1edcd9f77e2.tar.gz
redshift-ng-dc78015f323f5ed3c3b7a9f2e6d9c1edcd9f77e2.tar.bz2
redshift-ng-dc78015f323f5ed3c3b7a9f2e6d9c1edcd9f77e2.tar.xz
Merge branch 'geoclue2-provider'
Add GeoClue2 location provider
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 37a0308..eca9217 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -66,3 +66,11 @@ redshift_LDADD += \
$(GEOCLUE_LIBS) $(GEOCLUE_CFLAGS)
$(GLIB_LIBS) $(GLIB_CFLAGS)
endif
+
+if ENABLE_GEOCLUE2
+redshift_SOURCES += location-geoclue2.c location-geoclue2.h
+AM_CFLAGS += \
+ $(GEOCLUE2_CFLAGS)
+redshift_LDADD += \
+ $(GEOCLUE2_LIBS) $(GEOCLUE2_CFLAGS)
+endif