aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2014-12-06 15:32:50 -0500
committerJon Lund Steffensen <jonlst@gmail.com>2014-12-15 20:36:35 -0500
commit8839dcd530cbc8f5c7ae45a61d86bed05d2a6e8a (patch)
tree3a3e69b2711bfbde5c557192bf10ea544a4617a7 /src/Makefile.am
parentAdd Quartz (OSX) gamma adjustment method (diff)
downloadredshift-ng-8839dcd530cbc8f5c7ae45a61d86bed05d2a6e8a.tar.gz
redshift-ng-8839dcd530cbc8f5c7ae45a61d86bed05d2a6e8a.tar.bz2
redshift-ng-8839dcd530cbc8f5c7ae45a61d86bed05d2a6e8a.tar.xz
Add CoreLocation (OSX) location provider
Similarly to the Geoclue provider, the CoreLocation provider only requests the location on startup.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ba0406d..8d11a03 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -82,3 +82,18 @@ AM_CFLAGS += \
redshift_LDADD += \
$(GEOCLUE2_LIBS) $(GEOCLUE2_CFLAGS)
endif
+
+# Build CoreLocation module as a separate convenience
+# library since it is using a separate compiler
+# (Objective C).
+
+if ENABLE_CORELOCATION
+noinst_LTLIBRARIES = liblocation-corelocation.la
+liblocation_corelocation_la_SOURCES = \
+ location-corelocation.m location-corelocation.h
+liblocation_corelocation_la_OBJCFLAGS = \
+ $(CORELOCATION_CFLAGS)
+liblocation_corelocation_la_LIBADD = \
+ $(CORELOCATION_CFLAGS) $(CORELOCATION_LIBS)
+redshift_LDADD += liblocation-corelocation.la
+endif