aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2010-05-06 23:56:52 +0200
committerJon Lund Steffensen <jonlst@gmail.com>2010-05-06 23:56:52 +0200
commit52a5a370fd394585d4bbf69d4a637bf92bd5878d (patch)
treea653ca89b5a2acfd094533704ba224b802b880b5 /src/Makefile.am
parentDon't call setlocale if NLS was disabled. (diff)
downloadredshift-ng-52a5a370fd394585d4bbf69d4a637bf92bd5878d.tar.gz
redshift-ng-52a5a370fd394585d4bbf69d4a637bf92bd5878d.tar.bz2
redshift-ng-52a5a370fd394585d4bbf69d4a637bf92bd5878d.tar.xz
systemtime.c: Portably read current time on posix and windows.
w32gdi.c: Implements gamma ramp method for Windows GDI API. Use double as a cross platform time representation. Add WinGDI as a selectable method (currently limitied to minimum 4500K). Fix a bug where redshift would crash if RANDR failed and VidMode wasn't compiled in.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index f23ab0b..c46c9ba 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -11,11 +11,13 @@ bin_PROGRAMS = redshift
redshift_SOURCES = \
redshift.c \
colorramp.c colorramp.h \
- solar.c solar.h
+ solar.c solar.h \
+ systemtime.c systemtime.h
EXTRA_redshift_SOURCES = \
randr.c randr.h \
- vidmode.c vidmode.h
+ vidmode.c vidmode.h \
+ w32gdi.c w32gdi.h
AM_CFLAGS =
redshift_LDADD = @LIBINTL@
@@ -36,3 +38,8 @@ redshift_LDADD += \
$(X11_LIBS) $(X11_CFLAGS) \
$(XF86VM_LIBS) $(XF86VM_CFLAGS)
endif
+
+if ENABLE_WINGDI
+redshift_SOURCES += w32gdi.c w32gdi.h
+redshift_LDADD += -lgdi32
+endif