aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2014-03-22 20:13:00 +0100
committerJon Lund Steffensen <jonlst@gmail.com>2014-03-22 20:13:00 +0100
commit09efaddd23468ef3d906c13e3d725e2341d757be (patch)
tree01bba123ef11d342732eea114e9a4e509e3d3f5f /src/Makefile.am
parentUpdate Fedora spec file with systemd unit install (diff)
parentSupport for running Redshift without a graphical environment in Linux by using Direct Rendering Manager (diff)
downloadredshift-ng-09efaddd23468ef3d906c13e3d725e2341d757be.tar.gz
redshift-ng-09efaddd23468ef3d906c13e3d725e2341d757be.tar.bz2
redshift-ng-09efaddd23468ef3d906c13e3d725e2341d757be.tar.xz
Merge pull request #42 from maandree/gamma-drm
Support for running Redshift outside X using libdrm
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 06676d0..e83073b 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -18,6 +18,7 @@ redshift_SOURCES = \
gamma-dummy.c gamma-dummy.h
EXTRA_redshift_SOURCES = \
+ gamma-drm.c gamma-drm.h \
gamma-randr.c gamma-randr.h \
gamma-vidmode.c gamma-vidmode.h \
gamma-w32gdi.c gamma-w32gdi.h \
@@ -27,6 +28,13 @@ AM_CFLAGS =
redshift_LDADD = @LIBINTL@
EXTRA_DIST =
+if ENABLE_DRM
+redshift_SOURCES += gamma-drm.c gamma-drm.h
+AM_CFLAGS += $(DRM_CFLAGS)
+redshift_LDADD += \
+ $(DRM_LIBS) $(DRM_CFLAGS)
+endif
+
if ENABLE_RANDR
redshift_SOURCES += gamma-randr.c gamma-randr.h
AM_CFLAGS += $(XCB_CFLAGS) $(XCB_RANDR_CFLAGS)