aboutsummaryrefslogtreecommitdiffstats
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2014-04-13 22:10:34 +0200
committerJon Lund Steffensen <jonlst@gmail.com>2014-04-13 22:10:34 +0200
commit07c8ee9e76facbbd6e639fe45d36442217b65042 (patch)
treef5a3daea5374905ef19a5bd0faf7a8cd047cfa01 /src/Makefile.am
parentredshift-gtk: Fix crash when toggling state using the status icon (diff)
downloadredshift-ng-07c8ee9e76facbbd6e639fe45d36442217b65042.tar.gz
redshift-ng-07c8ee9e76facbbd6e639fe45d36442217b65042.tar.bz2
redshift-ng-07c8ee9e76facbbd6e639fe45d36442217b65042.tar.xz
Fix #67: Geoclue should pull in Glib as dependency
Add checks in configure.ac for Glib and pull in through Makefile.am when Geoclue support is enabled.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index e83073b..37a0308 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -59,7 +59,10 @@ endif
if ENABLE_GEOCLUE
redshift_SOURCES += location-geoclue.c location-geoclue.h
-AM_CFLAGS += $(GEOCLUE_CFLAGS) $(GEOCLUE_LIBS)
+AM_CFLAGS += \
+ $(GEOCLUE_CFLAGS) $(GEOCLUE_LIBS) \
+ $(GLIB_CFLAGS) $(GLIB_LIBS)
redshift_LDADD += \
$(GEOCLUE_LIBS) $(GEOCLUE_CFLAGS)
+ $(GLIB_LIBS) $(GLIB_CFLAGS)
endif