aboutsummaryrefslogtreecommitdiffstats
path: root/redshift-gtk/Makefile.am
diff options
context:
space:
mode:
authorMattias Andrée <m@maandree.se>2025-03-05 16:42:03 +0100
committerMattias Andrée <m@maandree.se>2025-03-05 16:42:03 +0100
commit4ad828611b4973bd71eb5cf91af0ac53bdda4c00 (patch)
tree589fef9e6ac8131a62c003be0ad380f0ad5de545 /redshift-gtk/Makefile.am
parentUnify header files (so far most) (diff)
downloadredshift-ng-4ad828611b4973bd71eb5cf91af0ac53bdda4c00.tar.gz
redshift-ng-4ad828611b4973bd71eb5cf91af0ac53bdda4c00.tar.bz2
redshift-ng-4ad828611b4973bd71eb5cf91af0ac53bdda4c00.tar.xz
Move redshift-gtk/ to root
Signed-off-by: Mattias Andrée <m@maandree.se>
Diffstat (limited to 'redshift-gtk/Makefile.am')
-rw-r--r--redshift-gtk/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/redshift-gtk/Makefile.am b/redshift-gtk/Makefile.am
new file mode 100644
index 0000000..b7303a2
--- /dev/null
+++ b/redshift-gtk/Makefile.am
@@ -0,0 +1,25 @@
+
+if ENABLE_GUI
+redshift_gtk_PYTHON = \
+ __init__.py \
+ controller.py \
+ statusicon.py \
+ utils.py
+nodist_redshift_gtk_PYTHON = \
+ defs.py
+redshift_gtkdir = $(pythondir)/redshift_gtk
+
+bin_SCRIPTS = redshift-gtk
+endif
+
+EXTRA_DIST = defs.py.in redshift-gtk.in
+CLEANFILES = defs.py redshift-gtk
+
+
+# Local python definitions
+defs.py: defs.py.in
+ $(AM_V_GEN)sed -e "s|\@bindir\@|$(bindir)|g" \
+ -e "s|\@localedir\@|$(localedir)|g" $< > $@
+
+redshift-gtk: redshift-gtk.in
+ $(AM_V_GEN)sed -e "s|\@pythondir\@|$(pythondir)|g" $< > $@