aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFrancesco Marella <francesco.marella@gmail.com>2010-06-04 12:42:31 +0200
committerFrancesco Marella <francesco.marella@gmail.com>2010-06-04 12:42:31 +0200
commita5b9ff65c421de27d81f9317a17467592fab3552 (patch)
treef6588aecf14ce07dc1273d1d73e95ae32e732d90 /configure.ac
parentAdd redshift-idle icon. (diff)
downloadredshift-ng-a5b9ff65c421de27d81f9317a17467592fab3552.tar.gz
redshift-ng-a5b9ff65c421de27d81f9317a17467592fab3552.tar.bz2
redshift-ng-a5b9ff65c421de27d81f9317a17467592fab3552.tar.xz
Add the autofoo needed to choose GTK+ status icon or app-indicator
Passing 'enable-appindicator=yes' to the configure script the GTK+ status icon will be disabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 24 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 89cb47a..e667f64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,27 @@ AS_IF([test "x$enable_gnome_clock" != xno], [
])
AM_CONDITIONAL([ENABLE_GNOME_CLOCK], [test "x$enable_gnome_clock" != xno])
+# Check for application indicator
+AC_MSG_CHECKING([whether to enable application indicator])
+AC_ARG_ENABLE([appindicator], [AC_HELP_STRING([--enable-appindicator],
+ [enable application indicator])],
+ [enable_appindicator=$enableval],[enable_appindicator=no])
+AS_IF([test "x$enable_appindicator" != xno], [
+ AS_IF([test $have_python = yes], [
+ AC_MSG_RESULT([yes])
+ enable_gtk=no
+ ], [
+ AC_MSG_RESULT([missing dependencies])
+ AS_IF([test "x$enable_appindicator" = xyes], [
+ AC_MSG_ERROR([application indicator script requires Python 2.6])
+ ])
+ enable_appindicator=no
+ ])
+], [
+ AC_MSG_RESULT([no])
+])
+AM_CONDITIONAL([ENABLE_APPINDICATOR], [test "x$enable_appindicator" != xno])
+
# Check for GTK+ status icon
AC_MSG_CHECKING([whether to enable GTK status icon])
AC_ARG_ENABLE([gtk], [AC_HELP_STRING([--enable-gtk],
@@ -168,4 +189,7 @@ echo "
compiler: ${CC}
cflags: ${CFLAGS}
ldflags: ${LDFLAGS}
+
+ gtk status icon: ${enable_gtk}
+ application indicator: ${enable_appindicator}
"