aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2009-11-04 23:53:09 +0100
committerJon Lund Steffensen <jonlst@gmail.com>2009-11-04 23:53:09 +0100
commit8cdffcee92181f505d9607e4bee779b8c80a84ba (patch)
treeaba77212a237dd2de8c4044283628d62a7df89a9 /configure.ac
parentAdd COPYING file (GPLv3). (diff)
downloadredshift-ng-8cdffcee92181f505d9607e4bee779b8c80a84ba.tar.gz
redshift-ng-8cdffcee92181f505d9607e4bee779b8c80a84ba.tar.bz2
redshift-ng-8cdffcee92181f505d9607e4bee779b8c80a84ba.tar.xz
Add autotools support.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac39
1 files changed, 39 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..07aaef8
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,39 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ([2.64])
+AC_INIT([redshift], [0.1], [jonlst@gmail.com])
+AC_CONFIG_SRCDIR([redshift.c])
+AC_CONFIG_HEADERS([config.h])
+AM_INIT_AUTOMAKE([dist-bzip2])
+
+# Checks for programs.
+AC_PROG_CC_C99
+
+# Checks for libraries.
+PKG_CHECK_MODULES([XCB], [xcb xcb-randr])
+
+# Checks for header files.
+AC_CHECK_HEADERS([locale.h stdint.h stdlib.h string.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_UINT16_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+AC_CHECK_FUNCS([pow setlocale strchr])
+
+AC_CONFIG_FILES([
+ Makefile
+])
+AC_OUTPUT
+
+
+echo "
+ $PACKAGE_NAME $VERSION
+
+ prefix: ${prefix}
+ compiler: ${CC}
+ cflags: ${CFLAGS}
+ ldflags: ${LDFLAGS}
+"