aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2013-12-09 14:07:01 -0500
committerJon Lund Steffensen <jonlst@gmail.com>2013-12-09 14:07:01 -0500
commit79bfe9eed44486fbf59e6d482abdbc649c41cee5 (patch)
tree9c08144295aef65bd98d427ed373c4e762a513e1 /configure.ac
parentgeoclue: Disable deprecated g_type_init() when glib >= 2.35 (diff)
downloadredshift-ng-79bfe9eed44486fbf59e6d482abdbc649c41cee5.tar.gz
redshift-ng-79bfe9eed44486fbf59e6d482abdbc649c41cee5.tar.bz2
redshift-ng-79bfe9eed44486fbf59e6d482abdbc649c41cee5.tar.xz
Remove Gnome Clock location provider
This was basically a hack that happened to work because the Gnome Clock applet could store the current location of the user, and Redshift was able to fetch this location through GConf. Since Redshift for some time now has supported a config file where the location can be set, there is not really any reason to use an external, fragile solution to do the same.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 0 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index 05455af..f7dbbe7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -22,8 +22,6 @@ PKG_CHECK_MODULES([XCB], [xcb], [have_xcb=yes], [have_xcb=no])
PKG_CHECK_MODULES([XCB_RANDR], [xcb-randr],
[have_xcb_randr=yes], [have_xcb_randr=no])
-PKG_CHECK_MODULES([GLIB], [glib-2.0 gobject-2.0], [have_glib=yes], [have_glib=no])
-PKG_CHECK_MODULES([GCONF], [gconf-2.0], [have_gconf=yes], [have_gconf=no])
PKG_CHECK_MODULES([GEOCLUE], [geoclue], [have_geoclue=yes], [have_geoclue=no])
AC_CHECK_HEADER([windows.h], [have_windows_h=yes], [have_windows_h=no])
@@ -103,29 +101,6 @@ AS_IF([test "x$enable_wingdi" != xno], [
])
AM_CONDITIONAL([ENABLE_WINGDI], [test "x$enable_wingdi" = xyes])
-# Check GNOME Clock location provider
-AC_MSG_CHECKING([whether to enable GNOME Clock location provider])
-AC_ARG_ENABLE([gnome-clock], [AC_HELP_STRING([--enable-gnome-clock],
- [enable GNOME Clock location provider])],
- [enable_gnome_clock=$enableval],[enable_gnome_clock=maybe])
-AS_IF([test "x$enable_gnome_clock" != xno], [
- AS_IF([test "x$have_glib" = "xyes" -a "x$have_gconf" = xyes], [
- AC_DEFINE([ENABLE_GNOME_CLOCK], 1,
- [Define to 1 to enable GNOME Clock location provider])
- AC_MSG_RESULT([yes])
- enable_gnome_clock=yes
- ], [
- AC_MSG_RESULT([missing dependencies])
- AS_IF([test "x$enable_gnome_clock" = xyes], [
- AC_MSG_ERROR([missing dependencies for GNOME Clock location provider])
- ])
- enable_gnome_clock=no
- ])
-], [
- AC_MSG_RESULT([no])
- enable_gnome_clock=no
-])
-AM_CONDITIONAL([ENABLE_GNOME_CLOCK], [test "x$enable_gnome_clock" = xyes])
# Check Geoclue location provider
AC_MSG_CHECKING([whether to enable Geoclue location provider])
@@ -220,7 +195,6 @@ echo "
WinGDI: ${enable_wingdi}
Location providers:
- GNOME Clock: ${enable_gnome_clock}
Geoclue: ${enable_geoclue}
GUI: ${enable_gui}