aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2010-06-13 23:53:36 +0200
committerJon Lund Steffensen <jonlst@gmail.com>2010-06-13 23:53:36 +0200
commit57afd85c003190daf853089a45acd03ffad8e63d (patch)
tree9ab9e6a0a10e4e1b9c4c34a49db08cebfdec0f32 /configure.ac
parentUpdate configure.ac for 1.4 release. (diff)
downloadredshift-ng-57afd85c003190daf853089a45acd03ffad8e63d.tar.gz
redshift-ng-57afd85c003190daf853089a45acd03ffad8e63d.tar.bz2
redshift-ng-57afd85c003190daf853089a45acd03ffad8e63d.tar.xz
Add missing file to Makefile.am.
Fix detection of GUI dependencies in configure.ac.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 06f148f..a608e9a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -141,22 +141,26 @@ AC_ARG_ENABLE([gui], [AC_HELP_STRING([--enable-gui],
[enable_gui=$enableval],[enable_gui=maybe])
# Statusicon GUI
-AS_IF([test "x$enable_gui" = xstatusicon -o "x$enable_gui" = maybe], [
- AS_IF([test $have_python != yes], [
+AS_IF([test "x$enable_gui" = xstatusicon -o "x$enable_gui" = xmaybe], [
+ AS_IF([test "x$have_python" != xyes], [
AS_IF([test "x$enable_gui" = xstatusicon], [
AC_MSG_ERROR([status icon script requires Python 2.6])
])
enable_gui=maybe
+ ], [
+ enable_gui=statusicon
])
])
# Appindicator GUI
-AS_IF([test "x$enable_gui" = xappindicator -o "x$enable_gui" = maybe], [
- AS_IF([test $have_python != yes], [
+AS_IF([test "x$enable_gui" = xappindicator -o "x$enable_gui" = xmaybe], [
+ AS_IF([test "x$have_python" != xyes], [
AS_IF([test "x$enable_gui" = xappindicator], [
AC_MSG_ERROR([application indicator script requires Python 2.6])
])
enable_gui=maybe
+ ], [
+ enable_gui=appindicator
])
])