aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2017-10-11 14:41:59 -0700
committerGitHub <noreply@github.com>2017-10-11 14:41:59 -0700
commit4ed2488e0893917c87612f38e0dc8ba42756710f (patch)
tree832e8e2c7dda78c66e1a2d2afaa7991494666cca /configure.ac
parentMerge pull request #527 from jonls/fix-osx-build (diff)
parentAdd AppArmor profile (diff)
downloadredshift-ng-4ed2488e0893917c87612f38e0dc8ba42756710f.tar.gz
redshift-ng-4ed2488e0893917c87612f38e0dc8ba42756710f.tar.bz2
redshift-ng-4ed2488e0893917c87612f38e0dc8ba42756710f.tar.xz
Merge pull request #528 from CameronNemo/apparmor
Add AppArmor profile
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 14663e2..be0b51a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -331,6 +331,21 @@ AS_IF([test -n "$with_systemduserunitdir" -a "x$with_systemduserunitdir" != xno]
AM_CONDITIONAL([ENABLE_SYSTEMD], [test "x$enable_systemd" != xno])
+# Check for AppArmor
+AC_MSG_CHECKING([whether to enable AppArmor profile])
+AC_ARG_ENABLE([apparmor], [AC_HELP_STRING([--enable-apparmor],
+ [enable AppArmor profile])],
+ [enable_apparmor=$enableval],[enable_apparmor=no])
+AS_IF([test "x$enable_apparmor" != xno], [
+ AC_MSG_RESULT([yes])
+ enable_apparmor=yes
+], [
+ AC_MSG_RESULT([no])
+ enable_apparmor=no
+])
+AM_CONDITIONAL([ENABLE_APPARMOR], [test "x$enable_apparmor" != xno])
+
+
# Checks for header files.
AC_CHECK_HEADERS([locale.h stdint.h stdlib.h string.h unistd.h signal.h])
@@ -373,4 +388,5 @@ echo "
GUI: ${enable_gui}
Ubuntu icons: ${enable_ubuntu}
systemd units: ${enable_systemd} ${systemduserunitdir}
+ AppArmor profile: ${enable_apparmor}
"