aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2010-01-14 00:53:33 +0100
committerJon Lund Steffensen <jonlst@gmail.com>2010-01-14 00:53:33 +0100
commit342e03883bf92a11c1a2e808b24e99274b3b1c04 (patch)
treea20d881d05f2372fa771d907d2bdad0b8475357f /configure.ac
parentFix: Typo in comment (diff)
downloadredshift-ng-342e03883bf92a11c1a2e808b24e99274b3b1c04.tar.gz
redshift-ng-342e03883bf92a11c1a2e808b24e99274b3b1c04.tar.bz2
redshift-ng-342e03883bf92a11c1a2e808b24e99274b3b1c04.tar.xz
Allow install of gtk-redshift script to be disabled in configure script.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1d9eb73..fd86cc6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,9 @@ PKG_CHECK_MODULES([XCB], [xcb], [have_xcb=yes], [have_xcb=no])
PKG_CHECK_MODULES([XCB_RANDR], [xcb-randr],
[have_xcb_randr=yes], [have_xcb_randr=no])
+# Check for Python
+AM_PATH_PYTHON([2.0], [have_python=yes], [have_python=no])
+
# Check RANDR method
AC_MSG_CHECKING([whether to enable RANDR method])
AC_ARG_ENABLE([randr], [AC_HELP_STRING([--enable-randr],
@@ -60,6 +63,23 @@ AS_IF([test "x$enable_randr" = xno -a "x$enable_vidmode" = xno], [
AC_MSG_ERROR([Either RANDR or VidMode must be enabled])
])
+# Check for GTK+ status icon
+AC_MSG_CHECKING([whether to enable GTK status icon])
+AC_ARG_ENABLE([gtk], [AC_HELP_STRING([--enable-gtk],
+ [enable GTK status icon])],
+ [enable_gtk=$enableval],[enable_gtk=yes])
+AS_IF([test "x$enable_gtk" != xno], [
+ AS_IF([test $have_python != yes], [
+ AC_MSG_WARN([The status icon script requires Python and PyGTK])
+ ])
+ AC_DEFINE([ENABLE_GTK], 1,
+ [Define to 1 to enable GTK+ status icon])
+ AC_MSG_RESULT([yes])
+], [
+ AC_MSG_RESULT([no])
+])
+AM_CONDITIONAL([ENABLE_GTK], [test "x$enable_gtk" != xno])
+
# Checks for header files.
AC_CHECK_HEADERS([locale.h stdint.h stdlib.h string.h unistd.h])