aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2011-03-28 00:14:58 +0200
committerJon Lund Steffensen <jonlst@gmail.com>2011-03-28 00:14:58 +0200
commit28d553ddbb1c1404a650987c8970958e0d52858c (patch)
tree00cf92b099149818bb5e9db2ef297145d4e3af4e /configure.ac
parentw32gdi: Obtain a new DC handle on every adjustment. This fixes a bug (diff)
parentAdd Makefile bits for geoclue provider to properly link against geoclue (diff)
downloadredshift-ng-28d553ddbb1c1404a650987c8970958e0d52858c.tar.gz
redshift-ng-28d553ddbb1c1404a650987c8970958e0d52858c.tar.bz2
redshift-ng-28d553ddbb1c1404a650987c8970958e0d52858c.tar.xz
Merge Geoclue location provider by Mathieu Trudel-Lapierre with some tweaks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 28 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 05bf8cb..261c4ec 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,6 +24,7 @@ PKG_CHECK_MODULES([XCB_RANDR], [xcb-randr],
PKG_CHECK_MODULES([GLIB], [glib-2.0 gobject-2.0], [have_glib=yes], [have_glib=no])
PKG_CHECK_MODULES([GCONF], [gconf-2.0], [have_gconf=yes], [have_gconf=no])
+PKG_CHECK_MODULES([GEOCLUE], [geoclue], [have_geoclue=yes], [have_geoclue=no])
AC_CHECK_HEADER([windows.h], [have_windows_h=yes], [have_windows_h=no])
@@ -113,7 +114,7 @@ AC_ARG_ENABLE([gnome-clock], [AC_HELP_STRING([--enable-gnome-clock],
[enable GNOME Clock location provider])],
[enable_gnome_clock=$enableval],[enable_gnome_clock=maybe])
AS_IF([test "x$enable_gnome_clock" != xno], [
- AS_IF([test $have_glib = yes -a $have_gconf = yes], [
+ AS_IF([test "x$have_glib" = "xyes" -a "x$have_gconf" = xyes], [
AC_DEFINE([ENABLE_GNOME_CLOCK], 1,
[Define to 1 to enable GNOME Clock location provider])
AC_MSG_RESULT([yes])
@@ -131,6 +132,31 @@ AS_IF([test "x$enable_gnome_clock" != xno], [
])
AM_CONDITIONAL([ENABLE_GNOME_CLOCK], [test "x$enable_gnome_clock" = xyes])
+# Check Geoclue location provider
+AC_MSG_CHECKING([whether to enable Geoclue location provider])
+AC_ARG_ENABLE([geoclue], [AC_HELP_STRING([--enable-geoclue],
+ [enable Geoclue location provider])],
+ [enable_geoclue=$enableval],[enable_geoclue=maybe])
+AS_IF([test "x$enable_geoclue" != xno], [
+ AS_IF([test "x$have_geoclue" = xyes], [
+ AC_DEFINE([ENABLE_GEOCLUE], 1,
+ [Define to 1 to enable Geoclue location provider])
+ AC_MSG_RESULT([yes])
+ enable_geoclue=yes
+ ], [
+ AC_MSG_RESULT([missing dependencies])
+ AS_IF([test "x$enable_geoclue" = xyes], [
+ AC_MSG_ERROR([missing dependencies for Geoclue location provider])
+ ])
+ enable_geoclue=no
+ ])
+], [
+ AC_MSG_RESULT([no])
+ enable_geoclue=no
+])
+AM_CONDITIONAL([ENABLE_GEOCLUE], [test "x$enable_geoclue" = xyes])
+
+
# Check for GUI status icon
AC_MSG_CHECKING([whether to enable GUI status icon])
AC_ARG_ENABLE([gui], [AC_HELP_STRING([--enable-gui],
@@ -187,6 +213,7 @@ echo "
Location providers:
GNOME Clock: ${enable_gnome_clock}
+ Geoclue: ${enable_geoclue}
GUI: ${enable_gui}
"