aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2014-04-13 22:10:34 +0200
committerJon Lund Steffensen <jonlst@gmail.com>2014-04-20 19:36:03 +0200
commit254b1e2a5704dddb077bde88f7c273f75902ef80 (patch)
tree86eacbe4c3a6a27461d906815e8dde7529df74ce /configure.ac
parentredshift-gtk: Fix crash when toggling state using the status icon (diff)
downloadredshift-ng-254b1e2a5704dddb077bde88f7c273f75902ef80.tar.gz
redshift-ng-254b1e2a5704dddb077bde88f7c273f75902ef80.tar.bz2
redshift-ng-254b1e2a5704dddb077bde88f7c273f75902ef80.tar.xz
Fix #67: Geoclue should pull in Glib as dependency
Add checks in configure.ac for Glib and pull in through Makefile.am when Geoclue support is enabled.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d4bfc68..339f0c8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,12 +17,14 @@ AM_GNU_GETTEXT_VERSION([0.17])
AM_GNU_GETTEXT([external])
PKG_CHECK_MODULES([DRM], [libdrm], [have_drm=yes], [have_drm=no])
+
PKG_CHECK_MODULES([X11], [x11], [have_x11=yes], [have_x11=no])
PKG_CHECK_MODULES([XF86VM], [xxf86vm], [have_xf86vm=yes], [have_xf86vm=no])
PKG_CHECK_MODULES([XCB], [xcb], [have_xcb=yes], [have_xcb=no])
PKG_CHECK_MODULES([XCB_RANDR], [xcb-randr],
[have_xcb_randr=yes], [have_xcb_randr=no])
+PKG_CHECK_MODULES([GLIB], [glib-2.0 gobject-2.0], [have_glib=yes], [have_glib=no])
PKG_CHECK_MODULES([GEOCLUE], [geoclue], [have_geoclue=yes], [have_geoclue=no])
AC_CHECK_HEADER([windows.h], [have_windows_h=yes], [have_windows_h=no])
@@ -133,7 +135,7 @@ AC_ARG_ENABLE([geoclue], [AC_HELP_STRING([--enable-geoclue],
[enable Geoclue location provider])],
[enable_geoclue=$enableval],[enable_geoclue=maybe])
AS_IF([test "x$enable_geoclue" != xno], [
- AS_IF([test "x$have_geoclue" = xyes], [
+ AS_IF([test "x$have_geoclue" = xyes -a "x$have_glib" = xyes], [
AC_DEFINE([ENABLE_GEOCLUE], 1,
[Define to 1 to enable Geoclue location provider])
AC_MSG_RESULT([yes])