aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2016-12-19 08:14:23 +0100
committerMattias Andrée <maandree@kth.se>2016-12-19 08:14:23 +0100
commit0d24c34d7fea73a0002a79e995f7c7f30b03a054 (patch)
tree01b6394e5f8b39047ed731ce82ffb193edef5b57 /configure.ac
parentMerge pull request #295 from arnej/windowsfix (diff)
downloadredshift-ng-0d24c34d7fea73a0002a79e995f7c7f30b03a054.tar.gz
redshift-ng-0d24c34d7fea73a0002a79e995f7c7f30b03a054.tar.bz2
redshift-ng-0d24c34d7fea73a0002a79e995f7c7f30b03a054.tar.xz
Add coopgamma backend
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 77cdf3f..61d31fb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -77,6 +77,9 @@ AS_IF([test "x$have_objc_compiler" = xyes], [
# Windows header
AC_CHECK_HEADER([windows.h], [have_windows_h=yes], [have_windows_h=no])
+# libcoopgamma header
+AC_CHECK_HEADER([libcoopgamma.h], [have_libcoopgamma_h=yes], [have_libcoopgamma_h=no])
+
# Check for Python
AM_PATH_PYTHON([3.2], [have_python=yes], [have_python=no])
@@ -204,6 +207,30 @@ AS_IF([test "x$enable_wingdi" != xno], [
])
AM_CONDITIONAL([ENABLE_WINGDI], [test "x$enable_wingdi" = xyes])
+# Check coopgamma method
+AC_MSG_CHECKING([whether to enable coopgamma method])
+AC_ARG_ENABLE([coopgamma], [AC_HELP_STRING([--enable-coopgamma],
+ [enable coopgamma method])],
+ [enable_coopgamma=$enableval],[enable_coopgamma=maybe])
+AS_IF([test "x$enable_coopgamma" != xno], [
+ AS_IF([test $have_libcoopgamma_h = yes], [
+ AC_DEFINE([ENABLE_COOPGAMMA], 1,
+ [Define to 1 to enable coopgamma method])
+ AC_MSG_RESULT([yes])
+ enable_coopgamma=yes
+ ], [
+ AC_MSG_RESULT([missing dependencies])
+ AS_IF([test "x$enable_coopgamma" = xyes], [
+ AC_MSG_ERROR([missing libcoopgamma headers for coopgamma method])
+ ])
+ enable_coopgamma=no
+ ])
+], [
+ AC_MSG_RESULT([no])
+ enable_coopgamma=no
+])
+AM_CONDITIONAL([ENABLE_COOPGAMMA], [test "x$enable_coopgamma" = xyes])
+
# Check Geoclue location provider
AC_MSG_CHECKING([whether to enable Geoclue location provider])
@@ -369,6 +396,7 @@ echo "
VidMode: ${enable_vidmode}
Quartz (OSX): ${enable_quartz}
WinGDI (Windows): ${enable_wingdi}
+ coopgamma: ${enable_coopgamma}
Location providers:
Geoclue: ${enable_geoclue}