aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2014-03-20 17:27:51 +0100
committerJon Lund Steffensen <jonlst@gmail.com>2014-03-20 17:27:51 +0100
commit00bb68332dfda66c2e98708d8c5eae693016a877 (patch)
treeeb24f48c2dd4f1d552c4ca2e3ce44d62de39ac52 /configure.ac
parentUpdate fedora spec file for Python3 dependency (diff)
parentAdd systemd user unit file for redshift-gtk (diff)
downloadredshift-ng-00bb68332dfda66c2e98708d8c5eae693016a877.tar.gz
redshift-ng-00bb68332dfda66c2e98708d8c5eae693016a877.tar.bz2
redshift-ng-00bb68332dfda66c2e98708d8c5eae693016a877.tar.xz
Merge branch 'systemd-service'
Add systemd user unit files for redshift and redshift-gtk. Fixes #35, fixes #50.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 550ed0f..c282e34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -161,6 +161,25 @@ AS_IF([test "x$enable_ubuntu" != xno], [
])
AM_CONDITIONAL([ENABLE_UBUNTU], [test "x$enable_ubuntu" != xno])
+
+# Check for systemd
+PKG_PROG_PKG_CONFIG
+AC_MSG_CHECKING([Directory to install systemd user unit files])
+AC_ARG_WITH([systemduserunitdir],
+ [AS_HELP_STRING([--with-systemduserunitdir=<dir>],
+ [Directory for systemd user unit files])],
+ [], [with_systemduserunitdir=$($PKG_CONFIG --variable=systemduserunitdir systemd)])
+AS_IF([test -n "$with_systemduserunitdir" -a "x$with_systemduserunitdir" != xno], [
+ AC_SUBST([systemduserunitdir], [$with_systemduserunitdir])
+ AC_MSG_RESULT([$systemduserunitdir])
+ enable_systemd=yes
+], [
+ AC_MSG_RESULT([not enabled])
+ enable_systemd=no
+])
+AM_CONDITIONAL([ENABLE_SYSTEMD], [test "x$enable_systemd" != xno])
+
+
# Checks for header files.
AC_CHECK_HEADERS([locale.h stdint.h stdlib.h string.h unistd.h signal.h])
@@ -200,4 +219,5 @@ echo "
GUI: ${enable_gui}
Ubuntu icons: ${enable_ubuntu}
+ systemd units: ${enable_systemd} ${systemduserunitdir}
"