aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorJon Lund Steffensen <jonlst@gmail.com>2014-05-28 20:56:37 -0400
committerJon Lund Steffensen <jonlst@gmail.com>2014-05-28 21:49:11 -0400
commit4697c37a83cbf581bf232f3f172dee6ff8e7faac (patch)
treeb0538891a5b860d4dbda16929bbc77567a4b5d6a /Makefile.am
parentMerge pull request #84 from maandree/geoclue-strdup-failure (diff)
downloadredshift-ng-4697c37a83cbf581bf232f3f172dee6ff8e7faac.tar.gz
redshift-ng-4697c37a83cbf581bf232f3f172dee6ff8e7faac.tar.bz2
redshift-ng-4697c37a83cbf581bf232f3f172dee6ff8e7faac.tar.xz
Make desktop file translatable
Changes bootstrap script to run libtoolize. Some extra magic was needed for autoreconf (taken from GNOME projects). The INTLTOOL_DESKTOP_RULE should be used in Makefile.am but is unfortunately broken at this time for out-of-source builds. The rule is instead copied and fixed in Makefile.am.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 9 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 675fda8..2743f62 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -26,8 +26,8 @@ _UBUNTU_MONO_LIGHT_FILES = \
data/icons/ubuntu-mono-light/scalable/apps/redshift-status-on.svg \
data/icons/ubuntu-mono-light/scalable/apps/redshift-status-off.svg
-_DESKTOP_FILES = \
- data/applications/redshift-gtk.desktop
+DESKTOP_IN_FILES = \
+ data/applications/redshift-gtk.desktop.in
SYSTEMD_USER_UNIT_IN_FILES = \
data/systemd/redshift.service.in \
@@ -52,7 +52,7 @@ endif
# Desktop file
if ENABLE_GUI
desktopdir = @datadir@/applications
-desktop_DATA = $(_DESKTOP_FILES)
+desktop_DATA = $(DESKTOP_IN_FILES:.desktop.in=.desktop)
endif
if ENABLE_GUI
@@ -61,6 +61,12 @@ install-data-hook:
uninstall-hook:
$(UPDATE_ICON_CACHE);
+
+# We would preferable use @INTLTOOL_DESKTOP_RULE@ here but
+# sadly it is broken for out-of-tree builds.
+%.desktop: %.desktop.in $(INTLTOOL_MERGE) $(wildcard $(top_srcdir)/po/*.po)
+ $(AM_V_GEN)$(MKDIR_P) $(@D);
+ $(INTLTOOL_V_MERGE)LC_ALL=C $(INTLTOOL_MERGE) $(INTLTOOL_V_MERGE_OPTIONS) -d -u -c $(top_builddir)/po/.intltool-merge-cache $(top_srcdir)/po $< $@
endif