aboutsummaryrefslogtreecommitdiffstats
path: root/xpybar/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--xpybar/PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/xpybar/PKGBUILD b/xpybar/PKGBUILD
new file mode 100644
index 0000000..9735eb1
--- /dev/null
+++ b/xpybar/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=xpybar
+pkgver=1.14
+pkgrel=1
+pkgdesc="A highly extensible minimalistic dock panel configured in Python 3"
+arch=(any)
+url="https://github.com/maandree/xpybar"
+license=('GPL3' 'AGPL3')
+depends=(python3 argparser python-xlib xorg-xrandr)
+optdepends=("linux: most of the monitors require Linux's procfs or sysfs"
+ "curl: for Internet services"
+ "python-pyalsaaudio: for ALSA volume control"
+ "hdparm: hdparm: for hdparm support"
+ "python-pytz: for timezone support"
+ "python-sysv-ipc: for ropty example"
+ "iputils: for ping support"
+ "inotify-tools: for inotify support"
+ "alarm: for limiting the time of a file search in locks"
+ "findutils: for file search in locks"
+ "graphicsmagick: for image support"
+ "imagemagick: for image support"
+ "file: for image support"
+ "librsvg: for image support")
+makedepends=(make coreutils sed zip auto-auto-complete texinfo)
+install=xpybar.install
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(22183b85da87094a7c5d454b76e6dc7b77bbb008914390ccfb153a0c36713f38)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr HDPARM_PATH=/usr/bin/hdpath
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr HDPARM_PATH=/usr/bin/hdpath install DESTDIR="$pkgdir"
+ chmod 4755 "$pkgdir/usr/bin/restricted-hdparm"
+}
+