aboutsummaryrefslogtreecommitdiffstats
path: root/xorg-server-hwcursor-gamma/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'xorg-server-hwcursor-gamma/PKGBUILD')
-rw-r--r--xorg-server-hwcursor-gamma/PKGBUILD49
1 files changed, 42 insertions, 7 deletions
diff --git a/xorg-server-hwcursor-gamma/PKGBUILD b/xorg-server-hwcursor-gamma/PKGBUILD
index e4578d0..6c331ec 100644
--- a/xorg-server-hwcursor-gamma/PKGBUILD
+++ b/xorg-server-hwcursor-gamma/PKGBUILD
@@ -5,10 +5,10 @@
_pkgname=xorg-server
pkgname=xorg-server-hwcursor-gamma
pkgver=1.17.1
-pkgrel=5
+pkgrel=7
pkgdesc="Xorg X server with patch to apply gamma ramps on hardware cursors"
depends=(libepoxy libxdmcp libxfont libpciaccess libdrm pixman libgcrypt libxau xorg-server-common xf86-input-evdev libxshmfence libgl)
-provides=("xorg-server=${pkgver}" 'X-ABI-VIDEODRV_VERSION=19' 'X-ABI-XINPUT_VERSION=21' 'X-ABI-EXTENSION_VERSION=9.0' 'x-server')
+provides=("xorg-server=${pkgver}" 'X-ABI-VIDEODRV_VERSION=19' 'X-ABI-XINPUT_VERSION=21.1' 'X-ABI-EXTENSION_VERSION=9.0' 'x-server')
conflicts=('xorg-server' 'nvidia-utils<=331.20' 'glamor-egl' 'xf86-video-modesetting')
replaces=('glamor-egl' 'xf86-video-modesetting')
arch=('i686' 'x86_64')
@@ -29,6 +29,13 @@ source=(${url}/releases/individual/xserver/${_pkgname}-${pkgver}.tar.bz2
v2-xserver-Fix-a-crash-with-XDMCP-error-handler.patch
0001-int10-Fix-error-check-for-pci_device_map_legacy.patch
0001-mi-Partial-pie-slice-filled-arcs-may-need-more-space.patch
+ 0001-sdksyms.sh-Make-sdksyms.sh-work-with-gcc5.patch
+ 0001-dix-Add-unaccelerated-valuators-to-the-ValuatorMask.patch
+ 0002-dix-hook-up-the-unaccelerated-valuator-masks.patch
+ fix-CVE-2015-3164.patch
+ systemd-logind-dont-second-guess-D-Bus-default-tim.patch
+ systemd-logind-filter-out-non-signal-messages-from.patch
+ 0001-modesetting-Fix-software-cursor-fallback.patch
0001-When-an-cursor-is-set-it-is-adjusted-to-use-the.patch
0002-Fix-for-full-and-semi-transparency-under-negative-im.patch
0003-Use-Harms-s-suggest-do-not-use-inline-if.-And-fix-si.patch)
@@ -40,25 +47,53 @@ sha256sums=('2bf8e9f6f0a710dec1d2472467bff1f4e247cb6dcd76eb469aafdc8a2d7db2ab'
'a73e33644682d9f430db987c192da0f7193907af50539669ebd59614a5ebd0f9'
'2ea82cdbd695f21c935710847913ed58e22d3d5c0c18c96175a4a6cc1142c071'
'ca89cc013844c5b50abfde4cc5e852ecdf4368f8b069ffd069a7100843c46e90'
+ 'b4a4fbddebfa614d1a97e77dde98748682ee331fbf7be394480050670d6203aa'
+ '3dc795002b8763a7d29db94f0af200131da9ce5ffc233bfd8916060f83a8fad7'
+ '416a1422eed71efcebb1d893de74e7f27e408323a56c4df003db37f5673b3f96'
+ 'bc6ac3e686e16f0357fd3b939c1c1f2845fdb444d5ec9c8c37fb69167cc54a28'
+ 'a8b9670844d784e9a0d6880f5689bbc107e071518acdbaa8c3ce5debca6b663b'
+ '97e4d5a6cfcf916889c493e232aec6f16d9447eb641bafb6e0afa9b27cfdc47e'
+ 'a0c0dbf5fe27994d52d5892c9c7cecf72792c5fa35db57b112ee7b17980faa75'
'bea348631dedd66475d84ac2cfe0840f22a80a642b4680d73fead4749e47f055'
'be9169b937b5d0b44f7f05d7c08aaa5f0c1092e128ce261d9cb350f09dfe1fb0'
'0a643ae83e03faee0f4db669a33c5b3c99edbba5c86cde2c83962ae536d31081')
prepare() {
cd "${_pkgname}-${pkgver}"
- # Apply hardware cursors gamma adjustments patchs
+
+ msg2 'Apply hardware cursors gamma adjustments patchs'
patch -Np1 -i ../0001-When-an-cursor-is-set-it-is-adjusted-to-use-the.patch
patch -Np1 -i ../0002-Fix-for-full-and-semi-transparency-under-negative-im.patch
patch -Np1 -i ../0003-Use-Harms-s-suggest-do-not-use-inline-if.-And-fix-si.patch
- # fix FS#43884, not yet upstream
+ msg2 'fix FS#43884, merged upstream'
patch -Np1 -i ../os-access-fix-regression-in-server-interpreted-auth.patch
- # partially fix FS#43867, not yet upstream
+
+ msg2 'partially fix FS#43867, merged upstream'
patch -Np1 -i ../v2-xserver-Fix-a-crash-with-XDMCP-error-handler.patch
- # fix FS#43924, merged upstream
+
+ msg2 'fix FS#43924, merged upstream'
patch -Np1 -i ../0001-int10-Fix-error-check-for-pci_device_map_legacy.patch
- # fix FS#43937, merged upstream
+
+ msg2 'fix FS#43937, merged upstream'
patch -Np1 -i ../0001-mi-Partial-pie-slice-filled-arcs-may-need-more-space.patch
+
+ msg2 'fix FS#45245, merged upstream'
+ patch -Np1 -i ../0001-sdksyms.sh-Make-sdksyms.sh-work-with-gcc5.patch
+
+ msg2 'fix FS#45229, merged upstream'
+ patch -Np1 -i ../0001-dix-Add-unaccelerated-valuators-to-the-ValuatorMask.patch
+ patch -Np1 -i ../0002-dix-hook-up-the-unaccelerated-valuator-masks.patch
+
+ msg2 'fix CVE-2015-3164, merged upstream'
+ patch -Np1 -i ../fix-CVE-2015-3164.patch
+
+ msg2 'Fix FS#44304, merged upstream'
+ patch -Np1 -i ../systemd-logind-filter-out-non-signal-messages-from.patch
+ patch -Np1 -i ../systemd-logind-dont-second-guess-D-Bus-default-tim.patch
+
+ msg2 'Fix software cursor fallback (possible fix for FS#44602)'
+ patch -Np1 -i ../0001-modesetting-Fix-software-cursor-fallback.patch
}
build() {