aboutsummaryrefslogtreecommitdiffstats
path: root/xcftools
diff options
context:
space:
mode:
Diffstat (limited to 'xcftools')
-rw-r--r--xcftools/.gitignore1
-rw-r--r--xcftools/PKGBUILD30
l---------xcftools/upload1
-rwxr-xr-xxcftools/watch20
-rw-r--r--xcftools/xcftools.patch27
5 files changed, 0 insertions, 79 deletions
diff --git a/xcftools/.gitignore b/xcftools/.gitignore
deleted file mode 100644
index ff3de76..0000000
--- a/xcftools/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-versions
diff --git a/xcftools/PKGBUILD b/xcftools/PKGBUILD
deleted file mode 100644
index a31dfbb..0000000
--- a/xcftools/PKGBUILD
+++ /dev/null
@@ -1,30 +0,0 @@
-# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
-# Previous maintainer: Jonathan Frawley <jonathanfrawley@gmail.com>
-
-pkgname=xcftools
-pkgver=1.0.7
-pkgrel=3
-pkgdesc="Miscellaneous command line tools for use with the open XCF format used by The GIMP"
-url="http://henning.makholm.net/software"
-arch=('x86_64' 'i686')
-license=('GPL2' 'perl')
-depends=('libpng' 'perl')
-optdepends=('gimp')
-makedepends=('libpng')
-source=("http://henning.makholm.net/xcftools/xcftools-${pkgver}.tar.gz"
- "xcftools.patch")
-md5sums=('fd960b6470fb23520fc4b1ade6cf6e25'
- '7439f6a8369a12913243ded6c93d31e1')
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- patch -i ../xcftools.patch
- ./configure --prefix=/usr
- make
-}
-
-package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
-}
-
diff --git a/xcftools/upload b/xcftools/upload
deleted file mode 120000
index 1e7a8be..0000000
--- a/xcftools/upload
+++ /dev/null
@@ -1 +0,0 @@
-../upload \ No newline at end of file
diff --git a/xcftools/watch b/xcftools/watch
deleted file mode 100755
index 09ac1eb..0000000
--- a/xcftools/watch
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-[ -f 'versions' ] && rm 'versions'
-wget http://henning.makholm.net/xcftools -O - | grep -Po '<a [^>]*>' | grep 'xcftools' | grep -v asc > versions
-if [ $? = 0 ]; then
- [ -f unfetchable ] && rm unfetchable
- md5sum < versions > new-sum
- touch sum
- if [ "$(cat sum)" = "$(cat new-sum)" ]; then
- rm new-sum
- else
- mv new-sum sum
- echo 'xcftools'
- fi
- rm versions
-elif [ ! -f unfetchable ]; then
- touch unfetchable
- echo 'xcftools (unfetchable)'
-fi
-
diff --git a/xcftools/xcftools.patch b/xcftools/xcftools.patch
deleted file mode 100644
index 1a2d88c..0000000
--- a/xcftools/xcftools.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -rupN xcftools-1.0.7.old/Makefile.in xcftools-1.0.7/Makefile.in
---- xcftools-1.0.7.old/Makefile.in 2009-07-03 11:31:56.000000000 +0100
-+++ xcftools-1.0.7/Makefile.in 2012-01-03 13:03:51.152358830 +0000
-@@ -79,7 +79,7 @@ xcf2pnm$e: xcf2pnm.$o $(FILEIO).$o enums
-
- xcf2png$e: xcf2png.$o $(FILEIO).$o enums.$o xcf-general.$o utils.$o nlsini.$o \
- pixels.$o flatten.$o flatspec.$o scaletab.$o table.$o palette.$o
-- $(CC) $(LDFLAGS) $(LIBS) -lpng $^ -o $@
-+ $(CC) $(LDFLAGS) $(LIBS) $^ -lpng -o $@
-
- xcfview: xcfview.in Makefile
- sed '1s,/usr/bin/perl,@PERL@,' < $< > $@
-diff -rupN xcftools-1.0.7.old/xcf2png.c xcftools-1.0.7/xcf2png.c
---- xcftools-1.0.7.old/xcf2png.c 2009-07-03 11:31:52.000000000 +0100
-+++ xcftools-1.0.7/xcf2png.c 2012-01-03 13:03:36.262509165 +0000
-@@ -71,9 +71,9 @@ init_output(void)
-
- outfile = openout(flatspec.output_filename);
- libpng = png_create_write_struct(PNG_LIBPNG_VER_STRING,
-- png_voidp_NULL,
-+ (png_voidp)NULL,
- my_error_callback,
-- png_error_ptr_NULL);
-+ (png_voidp)NULL);
- if( !libpng )
- FatalUnexpected(_("Couldn't initialize libpng library"));
-