aboutsummaryrefslogtreecommitdiffstats
path: root/qtchess
diff options
context:
space:
mode:
Diffstat (limited to 'qtchess')
-rw-r--r--qtchess/PKGBUILD33
l---------qtchess/upload1
-rwxr-xr-xqtchess/watch20
3 files changed, 0 insertions, 54 deletions
diff --git a/qtchess/PKGBUILD b/qtchess/PKGBUILD
deleted file mode 100644
index fb5fdd3..0000000
--- a/qtchess/PKGBUILD
+++ /dev/null
@@ -1,33 +0,0 @@
-# Maintainer: Mattias Andrée <m@`base64 -d`(bWFhbmRyZWU).se>
-# Contributor: kleintux <reg-archlinux AT klein DOT tuxli DOT ch>
-
-pkgname=qtchess
-pkgver=2021.03.15
-pkgrel=2
-pkgdesc='Online chess game client written in Qt'
-url='https://textbrowser.github.io/qtchess/'
-arch=('i686' 'x86_64')
-license=('custom:3-clause BSD')
-# (license notice included in qtchess_main.cc)
-depends=('qt5-base' 'libgl')
-makedepends=('qt5-base' 'libgl' 'qt5-tools')
-source=(qtchess-${pkgver}.tar.gz::"https://github.com/textbrowser/qtchess/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('b67e182beca7d203dd07b995a6d4cae752dc42ed76439694e1befe5d6bd5f2be')
-
-
-prepare () {
- cd "$srcdir/qtchess-${pkgver}"
- sed '/-Werror/d' < qtchess.pro > qtchess.pro.fixed
-}
-
-build () {
- cd "$srcdir/qtchess-${pkgver}"
- qmake-qt5 -o Makefile qtchess.pro.fixed
- make
-}
-
-package () {
- cd "$srcdir/qtchess-${pkgver}"
- mkdir -p -- "${pkgdir}/usr/bin/"
- cp -- QtChess "${pkgdir}/usr/bin/qtchess"
-}
diff --git a/qtchess/upload b/qtchess/upload
deleted file mode 120000
index 1e7a8be..0000000
--- a/qtchess/upload
+++ /dev/null
@@ -1 +0,0 @@
-../upload \ No newline at end of file
diff --git a/qtchess/watch b/qtchess/watch
deleted file mode 100755
index 05d5681..0000000
--- a/qtchess/watch
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-[ -f 'index.html' ] && rm 'index.html'
-wget http://qtchess.sourceforge.net/ >/dev/null 2>/dev/null
-if [ $? = 0 ]; then
- [ -f unfetchable ] && rm unfetchable
- grep 'has been released' < index.html | md5sum > new-sum
- touch sum
- if [ "$(cat sum)" = "$(cat new-sum)" ]; then
- rm new-sum
- else
- mv new-sum sum
- echo 'dooble'
- fi
- rm index.html
-elif [ ! -f unfetchable ]; then
- touch unfetchable
- echo 'dooble (unfetchable)'
-fi
-