aboutsummaryrefslogtreecommitdiffstats
path: root/pony
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--pony.computer/PKGBUILD34
-rw-r--r--pony.computer/pony.computer.install20
l---------pony.computer/upload (renamed from gtk3-print-backends-nocolord/upload)0
-rw-r--r--pony/.gitignore1
-rw-r--r--pony/PKGBUILD27
l---------pony/upload1
-rwxr-xr-xpony/watch20
-rw-r--r--ponyguests/PKGBUILD30
-rw-r--r--ponyguests/ponyguests.install20
l---------ponyguests/upload (renamed from javagnutar/upload)0
-rw-r--r--ponypipe/PKGBUILD2
11 files changed, 105 insertions, 50 deletions
diff --git a/pony.computer/PKGBUILD b/pony.computer/PKGBUILD
new file mode 100644
index 0000000..3b28106
--- /dev/null
+++ b/pony.computer/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mattias Andrée <m@`base64 -d`(bWFhbmRyZWU).se>
+
+pkgname=pony.computer
+pkgver=1428445028
+pkgrel=1
+pkgdesc="Show computer information and a pony"
+url="https://github.com/GNU-Pony/pony.computer"
+arch=(any)
+license=(GPL3)
+depends=(sh ponysay coreutils python3)
+optdepends=("linux: Additional system information can be provided with Linux kernel's procfs /proc"
+ "filesystem: Identification of distribution"
+ "lsb-release: Identification of distribution")
+makedepends=(make coreutils sed texinfo)
+install=pony.computer.install
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(997f8be119e36cbbdcafee2126ceccfac3e6551d839b78a93aba748f33d4469d)
+
+_prefix=/usr
+
+
+build() {
+ cd "${srcdir}/pony.computer-${pkgver}"
+ make PREFIX="${_prefix}" PKGNAME="${pkgname}" DISTRO="Arch Linux"
+}
+
+package() {
+ cd "${srcdir}/pony.computer-${pkgver}"
+ make PREFIX="${_prefix}" PKGNAME="${pkgname}" DESTDIR="${pkgdir}" install
+ _dir="${pkgdir}${_prefix}/share/licenses/${pkgname}"
+ mkdir -p -- "${_dir}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+
diff --git a/pony.computer/pony.computer.install b/pony.computer/pony.computer.install
new file mode 100644
index 0000000..2cb5cc3
--- /dev/null
+++ b/pony.computer/pony.computer.install
@@ -0,0 +1,20 @@
+_file="pony.computer"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
diff --git a/gtk3-print-backends-nocolord/upload b/pony.computer/upload
index 1e7a8be..1e7a8be 120000
--- a/gtk3-print-backends-nocolord/upload
+++ b/pony.computer/upload
diff --git a/pony/.gitignore b/pony/.gitignore
deleted file mode 100644
index 4139e4a..0000000
--- a/pony/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-/pony
diff --git a/pony/PKGBUILD b/pony/PKGBUILD
deleted file mode 100644
index 91f232b..0000000
--- a/pony/PKGBUILD
+++ /dev/null
@@ -1,27 +0,0 @@
-# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
-# Previous maintainer: Arch Haskell Team <arch-haskell@haskell.org>
-
-_hkgname=pony
-pkgname=pony
-pkgver=1.0
-pkgrel=3
-pkgdesc="Can I have a pony?"
-url="http://hackage.haskell.org/package/${_hkgname}"
-license=('custom:BSD3')
-arch=('i686' 'x86_64')
-makedepends=('ghc')
-depends=('gmp')
-options=('strip')
-source=(http://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz)
-build() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- runhaskell Setup configure --prefix=/usr --docdir=/usr/share/doc/${pkgname} -O
- runhaskell Setup build
-}
-package() {
- cd ${srcdir}/${_hkgname}-${pkgver}
- runhaskell Setup copy --destdir=${pkgdir}
- install -D -m644 LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- rm -f ${pkgdir}/usr/share/doc/${pkgname}/LICENSE
-}
-md5sums=('10ce264fbbe185a3f6290017c5ea58b2')
diff --git a/pony/upload b/pony/upload
deleted file mode 120000
index 1e7a8be..0000000
--- a/pony/upload
+++ /dev/null
@@ -1 +0,0 @@
-../upload \ No newline at end of file
diff --git a/pony/watch b/pony/watch
deleted file mode 100755
index 4668fdc..0000000
--- a/pony/watch
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/bin/sh
-
-[ -f 'pony' ] && rm 'pony'
-wget http://hackage.haskell.org/package/pony -O - | grep -Po 'pony-[^>]*' > pony 2>/dev/null
-if [ $? = 0 ]; then
- [ -f unfetchable ] && rm unfetchable
- md5sum < pony > new-sum
- touch sum
- if [ "$(cat sum)" = "$(cat new-sum)" ]; then
- rm new-sum
- else
- mv new-sum sum
- echo 'pony'
- fi
- rm pony
-elif [ ! -f unfetchable ]; then
- touch unfetchable
- echo 'pony (unfetchable)'
-fi
-
diff --git a/ponyguests/PKGBUILD b/ponyguests/PKGBUILD
new file mode 100644
index 0000000..682bdca
--- /dev/null
+++ b/ponyguests/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mattias Andrée <m@`base64 -d`(bWFhbmRyZWU).se>
+
+pkgname=ponyguests
+pkgver=1428445099
+pkgrel=1
+pkgdesc="Login wrapper to enable guest accounts"
+url="https://github.com/GNU-Pony/ponyguests"
+arch=(i686 x86_64)
+license=(GPL3)
+depends=(sh coreutils grep sed bc shadow 'linux>=3.4' glibc)
+makedepends=(make coreutils 'linux-api-headers>=3.4' glibc gcc sed texinfo)
+install=ponyguests.install
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(95105124ca7e4839f62e61352cddf416fe6aad761dc9558bef775787d7d863ce)
+
+build() {
+ cd "${srcdir}/ponyguests-${pkgver}"
+
+ make PKGNAME="${pkgname}"
+}
+
+package() {
+ cd "${srcdir}/ponyguests-${pkgver}"
+
+ make PKGNAME="${pkgname}" DESTDIR="${pkgdir}" install
+
+ _dir="${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+
diff --git a/ponyguests/ponyguests.install b/ponyguests/ponyguests.install
new file mode 100644
index 0000000..e2a45d7
--- /dev/null
+++ b/ponyguests/ponyguests.install
@@ -0,0 +1,20 @@
+_file="ponyguests"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
diff --git a/javagnutar/upload b/ponyguests/upload
index 1e7a8be..1e7a8be 120000
--- a/javagnutar/upload
+++ b/ponyguests/upload
diff --git a/ponypipe/PKGBUILD b/ponypipe/PKGBUILD
index e157e51..3033333 100644
--- a/ponypipe/PKGBUILD
+++ b/ponypipe/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Maintainer: Mattias Andrée <m@`base64 -d`(bWFhbmRyZWU).se>
pkgname=ponypipe
pkgver=1.2.4
pkgrel=1