aboutsummaryrefslogtreecommitdiffstats
path: root/libkeccak
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--libkeccak/PKGBUILD34
-rw-r--r--libkeccak/libkeccak.install20
l---------libkeccak/upload1
3 files changed, 55 insertions, 0 deletions
diff --git a/libkeccak/PKGBUILD b/libkeccak/PKGBUILD
new file mode 100644
index 0000000..fedac2e
--- /dev/null
+++ b/libkeccak/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=libkeccak
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Keccak-family hashing library"
+arch=(i686 x86_64)
+url="https://github.com/maandree/libkeccak"
+license=('AGPL3')
+depends=(glibc)
+checkdepends=(glibc valgrind make coreutils)
+makedepends=(glibc gcc make coreutils binutils texinfo)
+install=libkeccak.install
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(48eec8cbd3a90f4446d7d04a45e70becad6f3a4e7d156b66746404aeb24603a9)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
diff --git a/libkeccak/libkeccak.install b/libkeccak/libkeccak.install
new file mode 100644
index 0000000..aa88d6d
--- /dev/null
+++ b/libkeccak/libkeccak.install
@@ -0,0 +1,20 @@
+_file="libkeccak"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
diff --git a/libkeccak/upload b/libkeccak/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/libkeccak/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file