aboutsummaryrefslogtreecommitdiffstats
path: root/emacs-gtk2/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'emacs-gtk2/PKGBUILD')
-rw-r--r--emacs-gtk2/PKGBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/emacs-gtk2/PKGBUILD b/emacs-gtk2/PKGBUILD
index f787add..16d413e 100644
--- a/emacs-gtk2/PKGBUILD
+++ b/emacs-gtk2/PKGBUILD
@@ -1,13 +1,18 @@
-pkgname=emacs-gtk2
+#Maintainer: Mattias Andrée <maandree@operamail.com>
+#Official Arch Linux package repository [gtk3 version] maintainer: Juergen Hoetzel <juergen@archlinux.org>
+#Official Arch Linux package repository [gtk3 version] contributor: Renchi Raju <renchi@green.tam.uiuc.edu>
+
+_pkgname=emacs
+pkgname=$_pkgname-gtk2
pkgver=24.2
-pkgrel=2
+pkgrel=3
pkgdesc="The extensible, customizable, self-documenting real-time display editor. GTK2 version"
arch=('i686' 'x86_64')
url="http://www.gnu.org/software/emacs/emacs.html"
license=('GPL3')
depends=('librsvg' 'gpm' 'giflib' 'libxpm' 'libotf' 'm17n-lib' 'gtk2' 'hicolor-icon-theme' 'gconf' 'desktop-file-utils' 'alsa-lib' 'imagemagick')
install=emacs-gtk2.install
-source=(ftp://ftp.gnu.org/gnu/emacs/emacs-$pkgver.tar.bz2{,.sig})
+source=(ftp://ftp.gnu.org/gnu/emacs/$_pkgname-$pkgver.tar.bz2{,.sig})
md5sums=('1676803a50e8adc817fdaaebb9234f14' 'ca1766337f419ef827dd96d1ff78f158')
provides=('emacs')
conflicts=('emacs')
@@ -15,23 +20,21 @@ conflicts=('emacs')
build() {
cd "$srcdir"/emacs-$pkgver
- ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --localstatedir=/var --with-x-toolkit=gtk --with-xft
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib \
+ --localstatedir=/var --with-x-toolkit=gtk --with-xft
make
}
package() {
- cd "$srcdir"/emacs-$pkgver
+ cd "$srcdir"/$_pkgname-$pkgver
make DESTDIR="$pkgdir" install
# remove conflict with ctags package
mv "$pkgdir"/usr/bin/{ctags,ctags.emacs}
mv "$pkgdir"/usr/share/man/man1/{ctags.1.gz,ctags.emacs.1}
-
- # fix all the 777 perms on directories
- find "$pkgdir"/usr/share/emacs/$_majorver -type d -exec chmod 755 {} \;
-
+
# fix user/root permissions on usr/share files
- find "$pkgdir"/usr/share/emacs/$_majorver -exec chown root:root {} \;
+ find "$pkgdir"/usr/share/emacs/$pkgver -exec chown root:root {} \;
# fix perms on /var/games
chmod 775 "$pkgdir"/var/games