aboutsummaryrefslogtreecommitdiffstats
path: root/cerberus-logging
diff options
context:
space:
mode:
Diffstat (limited to 'cerberus-logging')
-rw-r--r--cerberus-logging/PKGBUILD32
-rw-r--r--cerberus-logging/cerberus-logging.install20
l---------cerberus-logging/upload1
3 files changed, 53 insertions, 0 deletions
diff --git a/cerberus-logging/PKGBUILD b/cerberus-logging/PKGBUILD
new file mode 100644
index 0000000..cd06939
--- /dev/null
+++ b/cerberus-logging/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWF0dGlhcy5hbmRyZWU)@protonmail.com>
+
+pkgname=cerberus-logging
+pkgver=1428445270
+pkgrel=1
+pkgdesc="Log-in logging extension for cerberus"
+url="https://github.com/GNU-Pony/cerberus-logging"
+arch=(i686 x86_64)
+license=(GPL3)
+depends=(glibc coreutils sh)
+optdepends=('audit: for logging with audit')
+makedepends=(make coreutils gcc glibc audit texinfo)
+install=cerberus-logging.install
+source=("${url}/archive/${pkgver}.tar.gz")
+sha256sums=(fedb5423eef21f108f1a293c17e625a3e49be9b891737b65b1284b6817ef59f1)
+
+build() {
+ cd "${srcdir}/cerberus-logging-${pkgver}"
+
+ LDFLAGS= make PKGNAME="${pkgname}" info btmp utmp lastlog syslog audit
+}
+
+package() {
+ cd "${srcdir}/cerberus-logging-${pkgver}"
+
+ make PKGNAME="${pkgname}" DESTDIR="${pkgdir}" install-base install-info \
+ install-btmp install-utmp install-lastlog install-syslog install-audit
+
+ _dir="${pkgdir}/usr/share/licenses/${pkgname}"
+ ln -sf -- "/usr/share/licenses/common/GPL3" "${_dir}/LICENSE"
+}
+
diff --git a/cerberus-logging/cerberus-logging.install b/cerberus-logging/cerberus-logging.install
new file mode 100644
index 0000000..dd40e58
--- /dev/null
+++ b/cerberus-logging/cerberus-logging.install
@@ -0,0 +1,20 @@
+_file="cerberus-logging"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
diff --git a/cerberus-logging/upload b/cerberus-logging/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/cerberus-logging/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file