aboutsummaryrefslogtreecommitdiffstats
path: root/cedilla
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--cedilla/PKGBUILD42
-rwxr-xr-xcedilla/watch17
2 files changed, 59 insertions, 0 deletions
diff --git a/cedilla/PKGBUILD b/cedilla/PKGBUILD
new file mode 100644
index 0000000..460f2fd
--- /dev/null
+++ b/cedilla/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
+pkgname=cedilla
+pkgver=0.6
+pkgrel=1
+pkgdesc="a simple text printer that uses Unicode internally"
+arch=(any)
+url="http://www.pps.jussieu.fr/~jch/software/cedilla/"
+license=('GPL')
+groups=()
+depends=(clisp texlive-core)
+makedepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(http://www.pps.jussieu.fr/~jch/software/files/$pkgname-$pkgver.tar.gz)
+noextract=()
+md5sums=('007948ffdec8ff4202ec5efff364ea22')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ ./compile-cedilla
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ # the install-cedilla script would not find the man path in fakeroot, so
+ # we need to create the dirs for it
+ source cedilla-config
+ mkdir -p $pkgdir/$MANDIR
+
+ TARGET=$pkgdir ./install-cedilla
+ sed -i -e 's/texmf-tetex/texmf-dist/g' $pkgdir/etc/cedilla-config.lisp
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/cedilla/watch b/cedilla/watch
new file mode 100755
index 0000000..daab691
--- /dev/null
+++ b/cedilla/watch
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+wget 'http://www.pps.univ-paris-diderot.fr/~jch/software/cedilla/NEWS.text' >/dev/null 2>/dev/null
+if [ $? = 0 ]; then
+ md5sum < NEWS.text > new-sum
+ touch sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'cedilla'
+ fi
+ rm NEWS.text
+else
+ echo 'cedilla (unfetchable)'
+fi
+