aboutsummaryrefslogtreecommitdiffstats
path: root/blender-plugin-vectex/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'blender-plugin-vectex/PKGBUILD')
-rw-r--r--blender-plugin-vectex/PKGBUILD14
1 files changed, 8 insertions, 6 deletions
diff --git a/blender-plugin-vectex/PKGBUILD b/blender-plugin-vectex/PKGBUILD
index 22ebc5d..fab4c02 100644
--- a/blender-plugin-vectex/PKGBUILD
+++ b/blender-plugin-vectex/PKGBUILD
@@ -1,5 +1,4 @@
-# Contributer: N30N <archlinux@alunamation.com>
-
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
pkgname=blender-plugin-vectex
pkgver=0.9
pkgrel=1
@@ -9,18 +8,21 @@ license="GPL"
arch=('i686' 'x86_64')
depends=('blender')
makedepends=()
-source=(http://vectex.googlecode.com/files/vectex-${pkgver}-fix.tar.bz2 '64bit.patch')
+source=("http://vectex.googlecode.com/files/vectex-${pkgver}-fix.tar.bz2" '64bit.patch')
md5sums=('e36937018056f072f35a8df3bb7574ad' '98ddd03b81bff9b2f923e8fd5e449b1b')
build() {
- cd $startdir/src/vectex-$pkgver
+ cd "$srcdir/vectex-$pkgver"
- if [ ${CARCH} == "x86_64" ]; then
+ if [ "${CARCH}" == "x86_64" ]; then
patch -p0 < $startdir/src/64bit.patch
fi
msg "Starting build process."
make || return 1
+}
- install -D -m755 vectex.so $startdir/pkg/usr/share/blender/plugins/texture/vectex.so
+package() {
+ install -D -m755 vectex.so "$pkgdir/usr/share/blender/plugins/texture/vectex.so"
}
+