aboutsummaryrefslogtreecommitdiffstats
path: root/blender-plugin-vectex/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'blender-plugin-vectex/PKGBUILD')
-rw-r--r--blender-plugin-vectex/PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/blender-plugin-vectex/PKGBUILD b/blender-plugin-vectex/PKGBUILD
new file mode 100644
index 0000000..22ebc5d
--- /dev/null
+++ b/blender-plugin-vectex/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributer: N30N <archlinux@alunamation.com>
+
+pkgname=blender-plugin-vectex
+pkgver=0.9
+pkgrel=1
+pkgdesc="Vectex is a SVG vector texture plugin for Blender"
+url="http://code.google.com/p/vectex/"
+license="GPL"
+arch=('i686' 'x86_64')
+depends=('blender')
+makedepends=()
+source=(http://vectex.googlecode.com/files/vectex-${pkgver}-fix.tar.bz2 '64bit.patch')
+md5sums=('e36937018056f072f35a8df3bb7574ad' '98ddd03b81bff9b2f923e8fd5e449b1b')
+
+build() {
+ cd $startdir/src/vectex-$pkgver
+
+ if [ ${CARCH} == "x86_64" ]; then
+ patch -p0 < $startdir/src/64bit.patch
+ fi
+
+ msg "Starting build process."
+ make || return 1
+
+ install -D -m755 vectex.so $startdir/pkg/usr/share/blender/plugins/texture/vectex.so
+}