aboutsummaryrefslogtreecommitdiffstats
path: root/alsause/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'alsause/PKGBUILD')
-rw-r--r--alsause/PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/alsause/PKGBUILD b/alsause/PKGBUILD
new file mode 100644
index 0000000..e8fdc32
--- /dev/null
+++ b/alsause/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+
+pkgname=alsause
+pkgver=1.0
+pkgrel=1
+pkgdesc="Set default ALSA PCM device"
+url='https://codeberg.org/maandree/alsause'
+arch=(i686 x86_64)
+license=('custom:ISC')
+depends=(libsimple libasound.so)
+makedepends=(libsimple libasound.so)
+source=($pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz)
+sha512sums=(e33c60915fcd8b54c13f685ed588480a27c7ce691ae1775eab639855e03561b7b00713c8759ade5eaeb5565c9a706043c90500fb869d8752381fbdc4a175a545)
+
+build () {
+ cd "$srcdir/alsause"
+ make PREFIX=/usr
+}
+
+package () {
+ cd "$srcdir/alsause"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+ make PREFIX=/usr DESTDIR="$pkgdir" post-install
+}