aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--gtk3-nobroadway-nowayland-nocolord/PKGBUILD57
-rw-r--r--gtk3-nobroadway-nowayland-nocolord/gtk3.install18
-rw-r--r--gtk3-nobroadway-nowayland-nocolord/settings.ini4
-rw-r--r--lib32-mesa-nowayland/LICENSE82
-rw-r--r--lib32-mesa-nowayland/PKGBUILD100
-rw-r--r--mesa-nowayland/LICENSE82
-rw-r--r--mesa-nowayland/PKGBUILD102
-rw-r--r--mpv-nowayland/PKGBUILD57
-rw-r--r--mpv-nowayland/mpv.install12
9 files changed, 514 insertions, 0 deletions
diff --git a/gtk3-nobroadway-nowayland-nocolord/PKGBUILD b/gtk3-nobroadway-nowayland-nocolord/PKGBUILD
new file mode 100644
index 0000000..e67e8db
--- /dev/null
+++ b/gtk3-nobroadway-nowayland-nocolord/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Maintainer of the gtk3 package: Ionut Biru <ibiru@archlinux.org>
+# Maintainer of the gtk3 package: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+
+pkgname=gtk3-nobroadway-nowayland-nocolord
+pkgver=3.18.6
+pkgrel=1
+pkgdesc="GObject-based multi-platform GUI toolkit"
+arch=(i686 x86_64)
+url="http://www.gtk.org/"
+depends=(atk cairo libcups libxcursor libxinerama libxrandr libxi libepoxy gdk-pixbuf2
+ libxcomposite libxdamage pango shared-mime-info at-spi2-atk libxkbcommon
+ adwaita-icon-theme json-glib rest librsvg gtk-update-icon-cache)
+makedepends=(gobject-introspection libcanberra)
+optdepends=('libcanberra: gtk3-widget-factory demo')
+install=gtk3.install
+license=(LGPL)
+conflicts=(gtk3)
+provides=("gtk3=$pkgver")
+source=(https://download.gnome.org/sources/gtk+/${pkgver:0:4}/gtk+-$pkgver.tar.xz
+ settings.ini)
+sha256sums=('78cabf0fd5a662f8723f62d5ac633072c76c557c1d700454c9c3deaa37e441ef'
+ '01fc1d81dc82c4a052ac6e25bf9a04e7647267cc3017bc91f9ce3e63e5eb9202')
+
+
+build() {
+ cd "gtk+-$pkgver"
+
+ CXX=/bin/false ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --enable-schemas-compile=no \
+ --enable-x11-backend \
+ --enable-broadway-backend=no \
+ --enable-wayland-backend=no \
+ --enable-mir-backend=no \
+ --enable-colord=no \
+ --enable-gtk-doc=no \
+ --enable-gtk-doc-html=no \
+ --enable-gtk-doc-pdf=no \
+ --enable-man=no
+
+ #https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd "gtk+-$pkgver"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 ../settings.ini "$pkgdir/usr/share/gtk-3.0/settings.ini"
+
+ # split this out to use with gtk2 too
+ rm "$pkgdir/usr/bin/gtk-update-icon-cache"
+}
+
diff --git a/gtk3-nobroadway-nowayland-nocolord/gtk3.install b/gtk3-nobroadway-nowayland-nocolord/gtk3.install
new file mode 100644
index 0000000..f57b1bf
--- /dev/null
+++ b/gtk3-nobroadway-nowayland-nocolord/gtk3.install
@@ -0,0 +1,18 @@
+post_install() {
+ /usr/bin/gtk-query-immodules-3.0 --update-cache
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+ /usr/bin/gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+pre_remove() {
+ rm -f /usr/lib/gtk-3.0/3.0.0/immodules.cache
+}
+
+post_remove() {
+ /usr/bin/glib-compile-schemas /usr/share/glib-2.0/schemas
+ /usr/bin/gtk-update-icon-cache -q -t -f /usr/share/icons/hicolor
+}
diff --git a/gtk3-nobroadway-nowayland-nocolord/settings.ini b/gtk3-nobroadway-nowayland-nocolord/settings.ini
new file mode 100644
index 0000000..921d1dd
--- /dev/null
+++ b/gtk3-nobroadway-nowayland-nocolord/settings.ini
@@ -0,0 +1,4 @@
+[Settings]
+gtk-icon-theme-name = Adwaita
+gtk-theme-name = Adwaita
+gtk-font-name = Cantarell 11
diff --git a/lib32-mesa-nowayland/LICENSE b/lib32-mesa-nowayland/LICENSE
new file mode 100644
index 0000000..ae33d27
--- /dev/null
+++ b/lib32-mesa-nowayland/LICENSE
@@ -0,0 +1,82 @@
+Disclaimer
+
+Mesa is a 3-D graphics library with an API which is very similar to
+that of OpenGL*
+To the extent that Mesa utilizes the OpenGL command syntax or state
+machine, it is being used with authorization from Silicon Graphics,
+Inc.(SGI). However, the author does not possess an OpenGL license
+from SGI, and makes no claim that Mesa is in any way a compatible
+replacement for OpenGL or associated with SGI. Those who want a
+licensed implementation of OpenGL should contact a licensed
+vendor.
+
+Please do not refer to the library as MesaGL (for legal
+reasons). It's just Mesa or The Mesa 3-D graphics
+library
+
+* OpenGL is a trademark of Silicon Graphics Incorporated.
+
+License / Copyright Information
+
+The Mesa distribution consists of several components. Different copyrights
+and licenses apply to different components. For example, GLUT is copyrighted
+by Mark Kilgard, some demo programs are copyrighted by SGI, some of the Mesa
+device drivers are copyrighted by their authors. See below for a list of
+Mesa's main components and the license for each.
+
+The core Mesa library is licensed according to the terms of the MIT license.
+This allows integration with the XFree86, Xorg and DRI projects.
+
+The default Mesa license is as follows:
+
+Copyright (C) 1999-2007 Brian Paul All Rights Reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+BRIAN PAUL BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
+AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+Attention, Contributors
+
+When contributing to the Mesa project you must agree to the licensing terms
+of the component to which you're contributing.
+The following section lists the primary components of the Mesa distribution
+and their respective licenses.
+
+
+Mesa Component Licenses
+
+Component Location Primary Author License
+----------------------------------------------------------------------------
+Main Mesa code src/mesa/ Brian Paul Mesa (MIT)
+
+Device drivers src/mesa/drivers/* See drivers See drivers
+
+Ext headers include/GL/glext.h SGI SGI Free B
+ include/GL/glxext.h
+
+GLUT src/glut/ Mark Kilgard Mark's copyright
+
+Mesa GLU library src/glu/mesa/ Brian Paul GNU-LGPL
+
+SGI GLU library src/glu/sgi/ SGI SGI Free B
+
+demo programs progs/demos/ various see source files
+
+X demos progs/xdemos/ Brian Paul see source files
+
+SGI demos progs/samples/ SGI SGI copyright
+
+RedBook demos progs/redbook/ SGI SGI copyright
diff --git a/lib32-mesa-nowayland/PKGBUILD b/lib32-mesa-nowayland/PKGBUILD
new file mode 100644
index 0000000..f847f5e
--- /dev/null
+++ b/lib32-mesa-nowayland/PKGBUILD
@@ -0,0 +1,100 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Contributor to the lib32-mesa package: Jan de Groot <jgc@archlinux.org>
+# Contributor to the lib32-mesa package: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=lib32-mesa-nowayland
+pkgver=11.0.7
+pkgrel=1
+arch=('x86_64')
+pkgdesc="an open-source implementation of the OpenGL specification (32-bit)"
+depends=('lib32-libdrm' 'lib32-libxxf86vm' 'lib32-libxdamage' 'lib32-libxshmfence' 'lib32-systemd'
+ 'lib32-elfutils' 'lib32-llvm-libs' 'lib32-libtxc_dxtn' 'lib32-expat' 'mesa' 'lib32-libxvmc' 'lib32-libxv')
+optdepends=('opengl-man-pages: for the OpenGL API man pages'
+ 'lib32-mesa-vdpau: for accelerated video playback')
+provides=('lib32-libglapi' 'lib32-osmesa' 'lib32-libgbm' 'lib32-libgles' 'lib32-libegl'
+ 'lib32-ati-dri' 'lib32-intel-dri' 'lib32-nouveau-dri' 'lib32-mesa-dri' "lib32-mesa=$pkgver")
+conflicts=("lib32-mesa" 'lib32-libglapi' 'lib32-osmesa' 'lib32-libgbm' 'lib32-libgles' 'lib32-libegl'
+ 'lib32-ati-dri' 'lib32-intel-dri' 'lib32-nouveau-dri' 'lib32-mesa-dri')
+replaces=("lib32-mesa=$pkgver" 'lib32-libglapi' 'lib32-osmesa' 'lib32-libgbm' 'lib32-libgles' 'lib32-libegl'
+ 'lib32-ati-dri' 'lib32-intel-dri' 'lib32-nouveau-dri' 'lib32-mesa-dri')
+makedepends=('python2-mako' 'lib32-libxml2' 'lib32-expat' 'lib32-libx11' 'glproto' 'lib32-libdrm' 'dri2proto' 'dri3proto' 'presentproto' 'lib32-libxvmc' 'lib32-libxv'
+ 'lib32-libxshmfence' 'lib32-libxxf86vm' 'lib32-libxdamage' 'gcc-multilib' 'lib32-elfutils' 'lib32-llvm' 'lib32-systemd'
+ 'lib32-libvdpau')
+url="http://mesa3d.sourceforge.net"
+license=('custom')
+source=(ftp://ftp.freedesktop.org/pub/mesa/${pkgver}/mesa-${pkgver}.tar.xz
+ LICENSE)
+sha256sums=('e7e90a332ede6c8fd08eff90786a3fd1605a4e62ebf3a9b514047838194538cb'
+ '7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2')
+
+prepare() {
+ cd ${srcdir}/?esa-*
+
+ # Fix detection of libLLVM when built with CMake
+ sed -i 's/LLVM_SO_NAME=.*/LLVM_SO_NAME=LLVM/' configure
+}
+
+build() {
+ export CC="gcc -m32"
+ export CXX="g++ -m32"
+ export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
+ export LLVM_CONFIG="/usr/bin/llvm-config32"
+
+ cd ${srcdir}/?esa-*
+
+ # our automake is far too new for their build system :)
+ # autoreconf -vfi
+
+ ./configure \
+ --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu \
+ --libdir=/usr/lib32 \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-dri-driverdir=/usr/lib32/xorg/modules/dri \
+ --with-gallium-drivers=r300,r600,radeonsi,nouveau,swrast \
+ --with-dri-drivers=i915,i965,r200,radeon,nouveau,swrast \
+ --with-egl-platforms=x11,drm \
+ --enable-llvm-shared-libs \
+ --enable-egl \
+ --enable-gbm \
+ --enable-gallium-llvm \
+ --enable-shared-glapi \
+ --enable-glx-tls \
+ --enable-dri \
+ --enable-glx \
+ --enable-osmesa \
+ --enable-gles1 \
+ --enable-gles2 \
+ --enable-texture-float \
+ --enable-nine \
+ --enable-vdpau
+
+ make
+
+ mkdir $srcdir/fakeinstall
+ make DESTDIR=${srcdir}/fakeinstall install
+}
+
+package() {
+ install -m755 -d ${pkgdir}/usr/lib32/xorg/modules/dri
+ # ati-dri, nouveay-dri, intel-dri, swrast
+ mv -v ${srcdir}/fakeinstall/usr/lib32/xorg/modules/dri/* ${pkgdir}/usr/lib32/xorg/modules/dri
+
+ install -m755 -d ${pkgdir}/usr/lib32
+ mv -v ${srcdir}/fakeinstall/usr/lib32/d3d ${pkgdir}/usr/lib32
+ mv -v ${srcdir}/fakeinstall/usr/lib32/*.so* ${pkgdir}/usr/lib32/
+
+ mv -v ${srcdir}/fakeinstall/usr/lib32/pkgconfig ${pkgdir}/usr/lib32/
+
+ install -m755 -d ${pkgdir}/usr/lib32/mesa
+ # move libgl/EGL/glesv*.so to not conflict with blobs - may break .pc files ?
+ mv -v ${pkgdir}/usr/lib32/libGL.so* ${pkgdir}/usr/lib32/mesa/
+ mv -v ${pkgdir}/usr/lib32/libEGL.so* ${pkgdir}/usr/lib32/mesa/
+ mv -v ${pkgdir}/usr/lib32/libGLES*.so* ${pkgdir}/usr/lib32/mesa/
+
+ # keep symlinks until pacman 4.2 FS#42046
+ #install -m755 -d "${pkgdir}/usr/share/licenses/lib32-mesa"
+ #install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/lib32-mesa/"
+ install -m755 -d "${pkgdir}/usr/share/licenses"
+ ln -s mesa "$pkgdir/usr/share/licenses/lib32-mesa"
+}
diff --git a/mesa-nowayland/LICENSE b/mesa-nowayland/LICENSE
new file mode 100644
index 0000000..ae33d27
--- /dev/null
+++ b/mesa-nowayland/LICENSE
@@ -0,0 +1,82 @@
+Disclaimer
+
+Mesa is a 3-D graphics library with an API which is very similar to
+that of OpenGL*
+To the extent that Mesa utilizes the OpenGL command syntax or state
+machine, it is being used with authorization from Silicon Graphics,
+Inc.(SGI). However, the author does not possess an OpenGL license
+from SGI, and makes no claim that Mesa is in any way a compatible
+replacement for OpenGL or associated with SGI. Those who want a
+licensed implementation of OpenGL should contact a licensed
+vendor.
+
+Please do not refer to the library as MesaGL (for legal
+reasons). It's just Mesa or The Mesa 3-D graphics
+library
+
+* OpenGL is a trademark of Silicon Graphics Incorporated.
+
+License / Copyright Information
+
+The Mesa distribution consists of several components. Different copyrights
+and licenses apply to different components. For example, GLUT is copyrighted
+by Mark Kilgard, some demo programs are copyrighted by SGI, some of the Mesa
+device drivers are copyrighted by their authors. See below for a list of
+Mesa's main components and the license for each.
+
+The core Mesa library is licensed according to the terms of the MIT license.
+This allows integration with the XFree86, Xorg and DRI projects.
+
+The default Mesa license is as follows:
+
+Copyright (C) 1999-2007 Brian Paul All Rights Reserved.
+
+Permission is hereby granted, free of charge, to any person obtaining a
+copy of this software and associated documentation files (the "Software"),
+to deal in the Software without restriction, including without limitation
+the rights to use, copy, modify, merge, publish, distribute, sublicense,
+and/or sell copies of the Software, and to permit persons to whom the
+Software is furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included
+in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+BRIAN PAUL BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN
+AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+Attention, Contributors
+
+When contributing to the Mesa project you must agree to the licensing terms
+of the component to which you're contributing.
+The following section lists the primary components of the Mesa distribution
+and their respective licenses.
+
+
+Mesa Component Licenses
+
+Component Location Primary Author License
+----------------------------------------------------------------------------
+Main Mesa code src/mesa/ Brian Paul Mesa (MIT)
+
+Device drivers src/mesa/drivers/* See drivers See drivers
+
+Ext headers include/GL/glext.h SGI SGI Free B
+ include/GL/glxext.h
+
+GLUT src/glut/ Mark Kilgard Mark's copyright
+
+Mesa GLU library src/glu/mesa/ Brian Paul GNU-LGPL
+
+SGI GLU library src/glu/sgi/ SGI SGI Free B
+
+demo programs progs/demos/ various see source files
+
+X demos progs/xdemos/ Brian Paul see source files
+
+SGI demos progs/samples/ SGI SGI copyright
+
+RedBook demos progs/redbook/ SGI SGI copyright
diff --git a/mesa-nowayland/PKGBUILD b/mesa-nowayland/PKGBUILD
new file mode 100644
index 0000000..668bf82
--- /dev/null
+++ b/mesa-nowayland/PKGBUILD
@@ -0,0 +1,102 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Maintainer of the mesa package: Jan de Groot <jgc@archlinux.org>
+# Maintainer of the mesa package: Andreas Radke <andyrtr@archlinux.org>
+
+pkgname=mesa-nowayland
+pkgver=11.0.7
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="an open-source implementation of the OpenGL specification"
+makedepends=('python2-mako' 'libxml2' 'libx11' 'glproto' 'libdrm' 'dri2proto' 'dri3proto' 'presentproto'
+ 'libxshmfence' 'libxxf86vm' 'libxdamage' 'libvdpau' 'libva' 'elfutils' 'llvm'
+ 'systemd' 'libomxil-bellagio' 'libclc' 'clang')
+depends=('libdrm' 'libxxf86vm' 'libxdamage' 'libxshmfence' 'systemd' 'elfutils'
+ 'libomxil-bellagio' 'expat' 'libtxc_dxtn' 'llvm-libs')
+optdepends=('opengl-man-pages: for the OpenGL API man pages'
+ 'mesa-vdpau: for accelerated video playback'
+ 'libva-mesa-driver: for accelerated video playback')
+conflicts=("mesa")
+provides=("mesa=$pkgver"
+ 'libglapi' 'osmesa' 'libgbm' 'libgles' 'libegl' 'khrplatform-devel'
+ 'ati-dri' 'intel-dri' 'nouveau-dri' 'svga-dri' 'mesa-dri')
+conflicts=('libglapi' 'osmesa' 'libgbm' 'libgles' 'libegl' 'khrplatform-devel'
+ 'ati-dri' 'intel-dri' 'nouveau-dri' 'svga-dri' 'mesa-dri')
+replaces=('libglapi' 'osmesa' 'libgbm' 'libgles' 'libegl' 'khrplatform-devel'
+ 'ati-dri' 'intel-dri' 'nouveau-dri' 'svga-dri' 'mesa-dri')
+url="http://mesa3d.sourceforge.net"
+license=('custom')
+source=(ftp://ftp.freedesktop.org/pub/mesa/${pkgver}/mesa-${pkgver}.tar.xz
+ LICENSE)
+sha256sums=('e7e90a332ede6c8fd08eff90786a3fd1605a4e62ebf3a9b514047838194538cb'
+ '7fdc119cf53c8ca65396ea73f6d10af641ba41ea1dd2bd44a824726e01c8b3f2')
+
+prepare() {
+ cd ${srcdir}/?esa-*
+
+ # Fix detection of libLLVM when built with CMake
+ sed -i 's/LLVM_SO_NAME=.*/LLVM_SO_NAME=LLVM/' configure
+}
+
+build() {
+ cd ${srcdir}/?esa-*
+
+ #autoreconf -vfi # our automake is far too new for their build system :)
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-dri-driverdir=/usr/lib/xorg/modules/dri \
+ --with-gallium-drivers=r300,r600,radeonsi,nouveau,svga,swrast \
+ --with-dri-drivers=i915,i965,r200,radeon,nouveau,swrast \
+ --with-egl-platforms=x11,drm \
+ --enable-llvm-shared-libs \
+ --enable-egl \
+ --enable-gbm \
+ --enable-gallium-llvm \
+ --enable-shared-glapi \
+ --enable-glx \
+ --enable-glx-tls \
+ --enable-dri \
+ --enable-osmesa \
+ --enable-gles1 \
+ --enable-gles2 \
+ --enable-texture-float \
+ --enable-xa \
+ --enable-vdpau \
+ --enable-omx \
+ --enable-nine \
+ --enable-opencl --enable-opencl-icd \
+ --with-clang-libdir=/usr/lib
+
+ # --help
+
+ make
+
+ # fake installation
+ mkdir $srcdir/fakeinstall
+ make DESTDIR=${srcdir}/fakeinstall install
+}
+
+package() {
+ install -m755 -d ${pkgdir}/etc
+ mv -v ${srcdir}/fakeinstall/etc/drirc ${pkgdir}/etc
+
+ install -m755 -d ${pkgdir}/usr/lib/xorg/modules/dri
+ # ati-dri, nouveau-dri, intel-dri, svga-dri, swrast
+ mv -v ${srcdir}/fakeinstall/usr/lib/xorg/modules/dri/* ${pkgdir}/usr/lib/xorg/modules/dri
+
+ mv -v ${srcdir}/fakeinstall/usr/lib/bellagio ${pkgdir}/usr/lib
+ mv -v ${srcdir}/fakeinstall/usr/lib/d3d ${pkgdir}/usr/lib
+ mv -v ${srcdir}/fakeinstall/usr/lib/*.so* ${pkgdir}/usr/lib/
+
+ mv -v ${srcdir}/fakeinstall/usr/include ${pkgdir}/usr
+ mv -v ${srcdir}/fakeinstall/usr/lib/pkgconfig ${pkgdir}/usr/lib/
+
+ install -m755 -d ${pkgdir}/usr/lib/mesa
+ # move libgl/EGL/glesv*.so to not conflict with blobs - may break .pc files ?
+ mv -v ${pkgdir}/usr/lib/libGL.so* ${pkgdir}/usr/lib/mesa/
+ mv -v ${pkgdir}/usr/lib/libEGL.so* ${pkgdir}/usr/lib/mesa/
+ mv -v ${pkgdir}/usr/lib/libGLES*.so* ${pkgdir}/usr/lib/mesa/
+
+ install -m755 -d "${pkgdir}/usr/share/licenses/mesa"
+ install -m644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/mesa/"
+}
diff --git a/mpv-nowayland/PKGBUILD b/mpv-nowayland/PKGBUILD
new file mode 100644
index 0000000..8c2efe2
--- /dev/null
+++ b/mpv-nowayland/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Maintainer of the mpv package: Christian Hesse <mail@eworm.de>
+# Contributor to the mpv package: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor to the mpv package: Eivind Uggedal <eivind@uggedal.com>
+
+_pkgname=mpv
+pkgname=mpv-nowayland
+epoch=1
+pkgver=0.14.0
+pkgrel=1
+pkgdesc='Video player based on MPlayer/mplayer2'
+arch=('i686' 'x86_64')
+license=('GPL')
+url='http://mpv.io'
+depends=(
+ 'ffmpeg' 'lcms2' 'libcdio-paranoia' 'libgl' 'enca' 'libxss'
+ 'libxinerama' 'libxv' 'libxkbcommon' 'libva' 'libcaca'
+ 'desktop-file-utils' 'hicolor-icon-theme' 'xdg-utils' 'lua52' 'libdvdnav'
+ 'libguess' 'libxrandr' 'jack' 'smbclient' 'rubberband'
+)
+makedepends=('mesa' 'python-docutils' 'ladspa' 'hardening-wrapper')
+optdepends=('youtube-dl: for video-sharing websites playback')
+options=('!emptydirs' '!buildflags')
+conflicts=("$_pkgname")
+provides=("$_pkgname=$pkgver")
+install=mpv.install
+source=("$_pkgname-$pkgver.tar.gz::https://github.com/mpv-player/$_pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('042937f483603f0c3d1dec11e8f0045e8c27f19eee46ea64d81a3cdf01e51233')
+
+prepare() {
+ cd ${_pkgname}-${pkgver}
+
+ ./bootstrap.py
+}
+
+build() {
+ cd ${_pkgname}-${pkgver}
+
+ ./waf configure --prefix=/usr \
+ --confdir=/etc/mpv \
+ --enable-zsh-comp \
+ --enable-libmpv-shared \
+ --enable-cdda \
+ --disable-wayland \
+ --disable-gl-wayland
+
+ ./waf build
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+
+ ./waf install --destdir="$pkgdir"
+
+ install -m644 DOCS/{encoding.rst,tech-overview.txt} \
+ "$pkgdir"/usr/share/doc/mpv
+}
diff --git a/mpv-nowayland/mpv.install b/mpv-nowayland/mpv.install
new file mode 100644
index 0000000..5c501dc
--- /dev/null
+++ b/mpv-nowayland/mpv.install
@@ -0,0 +1,12 @@
+post_install() {
+ xdg-icon-resource forceupdate --theme hicolor &> /dev/null
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}