aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--texman/PKGBUILD30
l---------texman/upload1
2 files changed, 31 insertions, 0 deletions
diff --git a/texman/PKGBUILD b/texman/PKGBUILD
new file mode 100644
index 0000000..41393e9
--- /dev/null
+++ b/texman/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+
+pkgname=texman
+pkgver=1.1
+pkgrel=1
+pkgdesc='Texinfo-like syntax for manpages'
+arch=('any')
+url='https://github.com/maandree/texman'
+license=('custom:ISC')
+depends=('perl')
+checkdepends=('perl')
+makedepends=('perl' 'coreutils' 'make')
+source=(texman-$pkgver.tar.gz::https://github.com/maandree/texman/archive/$pkgver.tar.gz)
+sha256sums=(e1a811b6d84cf88785e1801841f2e972c4dda90559f0368efa3ab7034d064719)
+
+
+build() {
+ cd "texman-${pkgver}"
+ make PREFIX=/usr
+}
+
+check() {
+ cd "texman-${pkgver}"
+ make check
+}
+
+package() {
+ cd "texman-${pkgver}"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
diff --git a/texman/upload b/texman/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/texman/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file