aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--texlive-flashcards/PKGBUILD25
-rwxr-xr-xtexlive-flashcards/watch21
2 files changed, 46 insertions, 0 deletions
diff --git a/texlive-flashcards/PKGBUILD b/texlive-flashcards/PKGBUILD
new file mode 100644
index 0000000..f4482d3
--- /dev/null
+++ b/texlive-flashcards/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Contributor: tze <tze@datalove.me>
+pkgname=texlive-flashcards
+pkgver=1.0.1
+pkgrel=1
+license=('GPL')
+depends=('texlive-core')
+pkgdesc="A class for typesetting flashcards."
+url="http://ctan.org/pkg/flashcards"
+arch=('any')
+install=texlive-flashcards.install
+source=(http://mirror.ctan.org/macros/latex/contrib/flashcards.zip)
+md5sums=('21f85c9b291a0d06e815ce09d89f4463')
+
+build()
+{
+ mkdir -p $pkgdir/usr/share/texmf/tex/latex/flashcards
+
+ cd $srcdir/flashcards
+ latex flashcards.ins
+ cp flashcards.cls $pkgdir/usr/share/texmf/tex/latex/flashcards
+ cp *.cfg $pkgdir/usr/share/texmf/tex/latex/flashcards
+
+ install -D $srcdir/flashcards/COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/texlive-flashcards/watch b/texlive-flashcards/watch
new file mode 100755
index 0000000..cd655ff
--- /dev/null
+++ b/texlive-flashcards/watch
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+[ -f flashcards ] && rm flashcards
+
+wget 'http://ctan.org/pkg/flashcards' -O flashcards >/dev/null 2>/dev/null
+
+if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
+ grep 'Ver&shy;sion' < flashcards | md5sum > new-sum
+ touch sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'texlive-flashcards'
+ fi
+elif [ ! -f unfetchable ]; then
+ touch unfetchable
+ echo 'texlive-flashcards (unfetchable)'
+fi
+