aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--libred/PKGBUILD26
l---------libred/upload1
2 files changed, 27 insertions, 0 deletions
diff --git a/libred/PKGBUILD b/libred/PKGBUILD
new file mode 100644
index 0000000..a111ef4
--- /dev/null
+++ b/libred/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@kth.se>
+
+pkgname=libred
+pkgver=1.0
+pkgrel=1
+pkgdesc="Solar elevation and blackbody colour calculation library for C"
+arch=(i686 x86_64)
+url="https://github.com/maandree/libred"
+license=('ISC')
+depends=()
+makedepends=(sed)
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(1a176a88e9c21ef507401b1da6ea05f4b73872e8eda8022e97e119afaa1192cc)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make install PREFIX=/usr DESTDIR="$pkgdir"
+}
+
diff --git a/libred/upload b/libred/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/libred/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file