aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--autopasswd/PKGBUILD25
l---------autopasswd/upload1
2 files changed, 26 insertions, 0 deletions
diff --git a/autopasswd/PKGBUILD b/autopasswd/PKGBUILD
new file mode 100644
index 0000000..d1faf65
--- /dev/null
+++ b/autopasswd/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=autopasswd
+pkgver=2
+pkgrel=2
+pkgdesc="Reproducable password generator"
+url="https://github.com/maandree/autopasswd"
+arch=(i686 x86_64)
+license=(GPL3)
+depends=(glibc libpassphrase argparser-c libkeccak)
+makedepends=(glibc libpassphrase argparser-c libkeccak make coreutils gcc)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=(7bdad6b035c198808ce650a3b78bd6476fbcf9663a4913b2d6e1a68ef0b1c270)
+
+
+build() {
+ cd "$srcdir/autopasswd-$pkgver"
+ make PREFIX=/usr
+}
+
+package() {
+ cd "$srcdir/autopasswd-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+
diff --git a/autopasswd/upload b/autopasswd/upload
new file mode 120000
index 0000000..1e7a8be
--- /dev/null
+++ b/autopasswd/upload
@@ -0,0 +1 @@
+../upload \ No newline at end of file