aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--dash-pipe/PKGBUILD22
-rwxr-xr-xdash-pipe/watch21
2 files changed, 43 insertions, 0 deletions
diff --git a/dash-pipe/PKGBUILD b/dash-pipe/PKGBUILD
new file mode 100644
index 0000000..c7000a0
--- /dev/null
+++ b/dash-pipe/PKGBUILD
@@ -0,0 +1,22 @@
+pkgname=dashpipe
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="A utility for ponifying and deponifying text"
+arch=('any')
+url="http://github.com/DanielOaks/$pkgname/"
+license=('MIT')
+depends=('perl')
+makedepends=('git')
+source=("https://github.com/DanielOaks/dashpipe/archive/v${pkgver}.tar.gz")
+sha256sums=('c8ed2242113bb5cd867ed934fe0f9745666c289711e70bb54a3c5903e04e3553')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/dash-pipe/watch b/dash-pipe/watch
new file mode 100755
index 0000000..2acc27b
--- /dev/null
+++ b/dash-pipe/watch
@@ -0,0 +1,21 @@
+#!/bin/sh
+
+[ -f release ] && rm release
+
+wget 'https://github.com/DanielOaks/dashpipe/releases' -O release >/dev/null 2>/dev/null
+
+if [ $? = 0 ]; then
+ [ -f unfetchable ] && rm unfetchable
+ grep -Po 'href="[^"]*\.tar\.gz"' < release | md5sum > new-sum
+ touch sum
+ if [ "$(cat sum)" = "$(cat new-sum)" ]; then
+ rm new-sum
+ else
+ mv new-sum sum
+ echo 'dashpipe'
+ fi
+elif [ ! -f unfetchable ]; then
+ touch unfetchable
+ echo 'dashpipe (unfetchable)'
+fi
+