aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--xorg-server-hwcursor-gamma/PKGBUILD11
-rw-r--r--xorg-server-hwcursor-gamma/call-eglBindAPI-after-eglInitialize.patch48
2 files changed, 3 insertions, 56 deletions
diff --git a/xorg-server-hwcursor-gamma/PKGBUILD b/xorg-server-hwcursor-gamma/PKGBUILD
index 854dee5..3fd6937 100644
--- a/xorg-server-hwcursor-gamma/PKGBUILD
+++ b/xorg-server-hwcursor-gamma/PKGBUILD
@@ -5,8 +5,8 @@
_pkgname=xorg-server
pkgname=xorg-server-hwcursor-gamma
epoch=2
-pkgver=1.18.3
-pkgrel=1 # 2 in xorg-server
+pkgver=1.18.4
+pkgrel=1
pkgdesc="Xorg X server with patch to apply gamma ramps on hardware cursors"
depends=(libepoxy libxdmcp libxfont libpciaccess libdrm pixman libgcrypt libxau xorg-server-common libxshmfence libgl xf86-input-evdev)
provides=("xorg-server=${pkgver}" 'X-ABI-VIDEODRV_VERSION=20' 'X-ABI-XINPUT_VERSION=22.1' 'X-ABI-EXTENSION_VERSION=9.0' 'x-server')
@@ -25,14 +25,12 @@ makedepends=('pixman' 'libx11' 'mesa' 'mesa-libgl' 'xf86driproto' 'xcmiscproto'
source=(${url}/releases/individual/xserver/${_pkgname}-${pkgver}.tar.bz2
xvfb-run
xvfb-run.1
- call-eglBindAPI-after-eglInitialize.patch
0001-When-an-cursor-is-set-it-is-adjusted-to-use-the.patch
0002-Fix-for-full-and-semi-transparency-under-negative-im.patch
0003-Use-Harms-s-suggest-do-not-use-inline-if.-And-fix-si.patch)
-sha256sums=('ea739c22517cdbe2b5f7c0a5fd05fe8a10ac0629003e71c0c7862f4bb60142cd'
+sha256sums=('278459b2c31d61a15655d95a72fb79930c480a6bb8cf9226e48a07df8b1d31c8'
'ff0156309470fc1d378fd2e104338020a884295e285972cc88e250e031cc35b9'
'2460adccd3362fefd4cdc5f1c70f332d7b578091fb9167bf88b5f91265bbd776'
- '45fdc2a1241d458756c41a93c01846e04cc75f3c75f81f48b61533d08280918d'
'bea348631dedd66475d84ac2cfe0840f22a80a642b4680d73fead4749e47f055'
'be9169b937b5d0b44f7f05d7c08aaa5f0c1092e128ce261d9cb350f09dfe1fb0'
'0a643ae83e03faee0f4db669a33c5b3c99edbba5c86cde2c83962ae536d31081')
@@ -44,9 +42,6 @@ prepare() {
patch -Np1 -i ../0001-When-an-cursor-is-set-it-is-adjusted-to-use-the.patch
patch -Np1 -i ../0002-Fix-for-full-and-semi-transparency-under-negative-im.patch
patch -Np1 -i ../0003-Use-Harms-s-suggest-do-not-use-inline-if.-And-fix-si.patch
-
- msg2 'Apply call-eglBindAPI-after-eglInitialize.patch'
- patch -Np1 -i ../call-eglBindAPI-after-eglInitialize.patch
}
build() {
diff --git a/xorg-server-hwcursor-gamma/call-eglBindAPI-after-eglInitialize.patch b/xorg-server-hwcursor-gamma/call-eglBindAPI-after-eglInitialize.patch
deleted file mode 100644
index 09773a2..0000000
--- a/xorg-server-hwcursor-gamma/call-eglBindAPI-after-eglInitialize.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff --git a/glamor/glamor_egl.c b/glamor/glamor_egl.c
-index 4bcd3ce..16a20a7 100644
---- a/glamor/glamor_egl.c
-+++ b/glamor/glamor_egl.c
-@@ -770,11 +770,6 @@ glamor_egl_init(ScrnInfoPtr scrn, int fd)
-
- glamor_egl->has_gem = glamor_egl_check_has_gem(fd);
-
--#ifndef GLAMOR_GLES2
-- eglBindAPI(EGL_OPENGL_API);
--#else
-- eglBindAPI(EGL_OPENGL_ES_API);
--#endif
- if (!eglInitialize
- (glamor_egl->display, &glamor_egl->major, &glamor_egl->minor)) {
- xf86DrvMsg(scrn->scrnIndex, X_ERROR, "eglInitialize() failed\n");
-@@ -782,6 +777,12 @@ glamor_egl_init(ScrnInfoPtr scrn, int fd)
- goto error;
- }
-
-+#ifndef GLAMOR_GLES2
-+ eglBindAPI(EGL_OPENGL_API);
-+#else
-+ eglBindAPI(EGL_OPENGL_ES_API);
-+#endif
-+
- version = eglQueryString(glamor_egl->display, EGL_VERSION);
- xf86Msg(X_INFO, "%s: EGL version %s:\n", glamor_name, version);
-
-diff --git a/hw/xwayland/xwayland-glamor.c b/hw/xwayland/xwayland-glamor.c
-index ad66cf6..73ccd71 100644
---- a/hw/xwayland/xwayland-glamor.c
-+++ b/hw/xwayland/xwayland-glamor.c
-@@ -298,12 +298,13 @@ xwl_drm_init_egl(struct xwl_screen *xwl_screen)
- return;
- }
-
-- eglBindAPI(EGL_OPENGL_API);
- if (!eglInitialize(xwl_screen->egl_display, &major, &minor)) {
- ErrorF("eglInitialize() failed\n");
- return;
- }
-
-+ eglBindAPI(EGL_OPENGL_API);
-+
- version = eglQueryString(xwl_screen->egl_display, EGL_VERSION);
- ErrorF("glamor: EGL version %s:\n", version);
-