aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--README2
-rw-r--r--scrotty/PKGBUILD27
-rw-r--r--scrotty/scrotty.install20
3 files changed, 48 insertions, 1 deletions
diff --git a/README b/README
index 61468e5..23afb05 100644
--- a/README
+++ b/README
@@ -1,4 +1,4 @@
-AUR* packages I maintain, but do not develop
+AUR* packages I maintain
*AUR = Arch (Linux) User Repository
diff --git a/scrotty/PKGBUILD b/scrotty/PKGBUILD
new file mode 100644
index 0000000..53c42be
--- /dev/null
+++ b/scrotty/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=scrotty
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Screenshot program for Linux's TTY"
+arch=(i686 x86_64)
+url="https://github.com/maandree/scrotty"
+license=('GPL3' 'custom:GFDL1.3')
+depends=(linux glibc imagemagick)
+makedepends=(make coreutils glibc gcc texinfo)
+install=scrotty.install
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(b8e6e157b795807ca44ab0e6ac178d0f3071c0e8df513dc50dabb1bafb877514)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr install DESTDIR="$pkgdir"
+}
+
diff --git a/scrotty/scrotty.install b/scrotty/scrotty.install
new file mode 100644
index 0000000..8e40299
--- /dev/null
+++ b/scrotty/scrotty.install
@@ -0,0 +1,20 @@
+_file="scrotty"
+
+infodir="usr/share/info"
+file="${_file}.info"
+
+
+post_install() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+
+post_upgrade() {
+ post_install "$1"
+}
+
+pre_remove() {
+ [[ -x "usr/bin/install-info" ]] || return 0
+ install-info --delete -- "${infodir}/${file}" "${infodir}/dir" 2> /dev/null
+}
+