aboutsummaryrefslogtreecommitdiffstats
path: root/libkeccak/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2017-02-10 18:17:01 +0100
committerMattias Andrée <maandree@kth.se>2017-02-10 18:17:01 +0100
commit51d8621963d89b3348885d6af69f916e74485073 (patch)
treeba2fc226255d3d048d4476a1986e5798c5c88249 /libkeccak/PKGBUILD
parentFix makedeps for cg-tools (diff)
downloadaur-packages-51d8621963d89b3348885d6af69f916e74485073.tar.gz
aur-packages-51d8621963d89b3348885d6af69f916e74485073.tar.bz2
aur-packages-51d8621963d89b3348885d6af69f916e74485073.tar.xz
Add libkeccak
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to '')
-rw-r--r--libkeccak/PKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/libkeccak/PKGBUILD b/libkeccak/PKGBUILD
new file mode 100644
index 0000000..fedac2e
--- /dev/null
+++ b/libkeccak/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+
+pkgname=libkeccak
+pkgver=1.1.1
+pkgrel=1
+pkgdesc="Keccak-family hashing library"
+arch=(i686 x86_64)
+url="https://github.com/maandree/libkeccak"
+license=('AGPL3')
+depends=(glibc)
+checkdepends=(glibc valgrind make coreutils)
+makedepends=(glibc gcc make coreutils binutils texinfo)
+install=libkeccak.install
+source=($url/archive/$pkgver.tar.gz)
+sha256sums=(48eec8cbd3a90f4446d7d04a45e70becad6f3a4e7d156b66746404aeb24603a9)
+
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr
+}
+
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make check
+}
+
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make PREFIX=/usr DESTDIR="$pkgdir" install
+}
+