aboutsummaryrefslogtreecommitdiffstats
path: root/gtk3-print-backends-nocolord/PKGBUILD
diff options
context:
space:
mode:
authorMattias Andrée <maandree@kth.se>2016-11-22 01:04:48 +0100
committerMattias Andrée <maandree@kth.se>2016-11-22 01:04:48 +0100
commit13aacb8f9439fd3a29ea27ecebe35b006262f3e4 (patch)
treecfacba1b264a98b60c3403ed25fa2f5a62c8fd30 /gtk3-print-backends-nocolord/PKGBUILD
parentupdate gtk3-nobroadway-nowayland-nocolord (diff)
downloadaur-packages-13aacb8f9439fd3a29ea27ecebe35b006262f3e4.tar.gz
aur-packages-13aacb8f9439fd3a29ea27ecebe35b006262f3e4.tar.bz2
aur-packages-13aacb8f9439fd3a29ea27ecebe35b006262f3e4.tar.xz
update mesa-nowayland and add gtk3-print-backends-nocolord
Signed-off-by: Mattias Andrée <maandree@kth.se>
Diffstat (limited to '')
-rw-r--r--gtk3-print-backends-nocolord/PKGBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/gtk3-print-backends-nocolord/PKGBUILD b/gtk3-print-backends-nocolord/PKGBUILD
new file mode 100644
index 0000000..c6ce272
--- /dev/null
+++ b/gtk3-print-backends-nocolord/PKGBUILD
@@ -0,0 +1,68 @@
+# Maintainer: Mattias Andrée <`base64 -d`(bWFhbmRyZWUK)@member.fsf.org>
+# Maintainer of the gtk3-print-backends package: Ionut Biru <ibiru@archlinux.org>
+# Maintainer of the gtk3-print-backends package: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
+
+pkgname=gtk3-print-backends-nocolord
+pkgver=3.22.4
+pkgrel=1
+pkgdesc="Print backends for GTK3"
+arch=(i686 x86_64)
+url="http://www.gtk.org/"
+depends=(gtk3 rest libcups)
+makedepends=(gobject-introspection libcanberra git rest libcups)
+license=(LGPL)
+_commit=4569bb372f838a9a68c9b134ef18865abe77001c # tags/3.22.4^0
+source=("git://git.gnome.org/gtk+#commit=$_commit")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd gtk+
+ git describe --tags | sed 's/-/+/g'
+}
+
+prepare() {
+ mkdir -p print-backends
+ cd gtk+
+ NOCONFIGURE=1 ./autogen.sh
+}
+
+build() {
+ cd gtk+
+
+ CXX=/bin/false ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-schemas-compile \
+ --enable-x11-backend \
+ --disable-broadway-backend \
+ --disable-wayland-backend \
+ --disable-gtk-doc \
+ --disable-colord
+
+ #https://bugzilla.gnome.org/show_bug.cgi?id=655517
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+
+ make
+}
+
+package() {
+ cd gtk+
+ make DESTDIR="$pkgdir" install
+
+ # split this out to use with gtk2 too
+ rm "$pkgdir/usr/bin/gtk-update-icon-cache"
+
+ cd "$pkgdir"
+ for _f in usr/lib/*/*/printbackends/*; do
+ case $_f in
+ *-file.so|*-lpr.so) continue;;
+ esac
+
+ mkdir -p "$srcdir/print-backends/${_f%/*}"
+ mv "$_f" "$srcdir/print-backends/$_f"
+ done
+
+ cd "$srcdir/"
+ rm -rf "$pkgdir"/*
+ mv print-backends/* "$pkgdir"
+}